new forum and Firefox



  • I just wanted to note if you use Firefox and tinker with your about:config settings the new forum does not like setting network.http.sendRefererHeader = 1 (send referer with links only). The default is network.http.sendRefererHeader = 2 which means send a referer with links and images. This is the first site I've ever come across having troubles with not sending a referer header for images but I wanted to pass it along.



  • Hi there -- Julian from NodeBB here. Interesting report re: sendRefererHeader.

    We don't account for the browser forcing a header, but to my knowledge the only mucking around with referrer is appending noreferrer to links pointing externally. What do you see when it happens?

    Feel free to file a bug at our GitHub repo if you can easily reproduce it. Thanks.



  • I'm unable to click reply until I reset this about:config pref. The first thing I noticed, though, was the error msg "Looks like your connection to Netgate Forum was lost, please wait while we try to reconnect." in a little pop-up alert in the lower right-hand corner of the page.



  • I'd like to thank you for posting this topic. I couldn't figure out why I couldn't reply/post. I thought I broke Firefox somehow. I made this change and BAM!, It worked. I don't know why, how or what. Regardless, I had to change this setting to '2' in order to post/reply.



  • @jawz101 said in new forum and Firefox:

    network.http.sendRefererHeader

    I use FF. I've never heard of this setting but when I checked, mine was set to 2.



  • @KOM said in new forum and Firefox:

    @jawz101 said in new forum and Firefox:

    network.http.sendRefererHeader

    I use FF. I've never heard of this setting but when I checked, mine was set to 2.

    I've hardened my FF configuration a few times. It's entirely possible I changed the setting in an effort to secure my FF. As with most 'hardening' changes, there are drawbacks.

    Whether the default was '2' or something else, it's good to know that's required for this forum.

    If/when I have more time, I'll investigate the drawbacks to this setting (to '2').


  • Rebel Alliance Developer Netgate

    There used to be some FF addons that let you set that on a per-site or global basis. Not sure if any are still around. I used to always run with that set to send the page being loaded as the referring URL, but there were always some sites that ran better one way or another.


Log in to reply