[gelöst]Traffic Shaping funktioniert nicht so wie es soll.



  • Hallo Forianer.

    Möchte gerne den Traffic priorisieren:

    -VoIP mit einer FritzBox als DECT-Station
    -dem TV soll für Netflix minimum 3,5 Mbit/s zur Verfügung stehen
    -der Rest soll surfen können
    -einige Dienste wie FTP, Torrent, WebDAV oder CalAV haben die geringste Prio

    Es stehen 6 Mbit/s Download und 2 Mbit/s Upload zur Verfügung, mehr gibt es hier noch nicht.

    Was wurde getan:

    Habe den Wizzard durchlaufen lassen und den Queue "qUltrahigh" erstellt.
    0_1528282337102_ts3.png

    den passenden Eintrag unter Floating erstellt:
    0_1528282436888_ts5.png

    und die jeweiligen Rules konfiguriert:
    0_1528282585326_ts4.png

    Nur läuft der ganze Upload über den Floatingrule "qOtherLow" und der Download über "qLink", also nicht über die Queues, wo es laufen soll. wo ist der Fehler?

    Viel Hilfe in den weiten des Internets gab es nicht. Da gibt es bei Youtube einige Vids, wie man sich artig durch den Wizzard klickt. Viele verweisen auf den Traffic Shaping Guide, der hier auch nicht weiterhilft. So paar Screenshots von funktionierenden Konfigurationen wäre hilfreich und nett.

    Danke schonmal im voraus

    ps: Was habt ihr hier mit dem Forum angestellt.



  • @mike69
    Warum machst du nicht einfach mal den Wizard und fügst dann deine eine Queue zusätzlich hinzu? Damit hättest du schon mal gesehen, dass unter WAN keine Regeln erstellt werden sondern ausschließlich unter den Floating Rules. Floating Rules werden als erstes abgearbeitet und dann die Interface Rules.
    Desweiteren sehen deine beiden Floating Rules "Netflix" und "guests" gleich aus. Nach welchen Kriterien soll denn der Traffic jetzt in der Queue landen?
    Du musst dich schon für den richtigen Filter entscheiden. Entweder Protokoll (TCP/UDP/ICMP etc), Destination (IP oder FQDN oder Alias Tabelle) oder bestimmt Ports.
    Netflix wird sicherlich auch schwer zu filtern sein, da sie ein riesengroßes CDN haben und mittlerweile sogar Content Appliances beim eigenen Netzbetreiber stehen.

    https://media.netflix.com/de/company-blog/how-netflix-works-with-isps-around-the-globe-to-deliver-a-great-viewing-experience

    Kann dir jetzt leider keine Beispiele liefern, da ich den Traffic Shaper aktuell nicht nutze und bei meinen Tests die gewünschten Ergebnisse hinter den Erwartungen zurücklagen.



  • Falls Netflix auf einem bestimmten Endgerät, z.B. TV geschaut wird, würde ich die IP des TV's mit der Queue belegen.



  • @m0nji said in Traffic Shaping funktioniert nicht so wie es soll.:

    Warum machst du nicht einfach mal den Wizard und fügst dann deine eine Queue zusätzlich hinzu? Damit hättest du schon mal gesehen, dass unter WAN keine Regeln erstellt werden sondern ausschließlich unter den Floating Rules. Floating Rules werden als erstes abgearbeitet und dann die Interface Rules.

    Hat vorher nicht so geklappt, da ging das wilde rumprobieren los. Also werde ich die Änderungen unter Rules/WAN zurücknehmen und unter Floating die die passenden Einträge ändern.

    Netflix und guests sind leer, weil die Queues unter Rules/WAN geändert worden sind. so wie hier:
    0_1528299462750_ts4.png

    Also Queues unter WAN auf "none" und die IPs bzw. Ports dann unter Floating eigene Regeln erstellen.

    Danke für den Hinweis.

    ps: Ist das so richtig?
    0_1528300963166_pfSense.home - Firewall: Rules: Floating - Mozilla Firefox_036.png

    ps2:
    Jens, kannst du Beitrag 5 richtig löschen? Wollte nicht zitieren, nur bearbeiten.



  • @mike69
    wieso inbound? netflix macht doch keinen connect zu dir sondern du zu netflix. destination müssten also die netflix server sein und source dein tv.
    gib als source mal die 192.168.2.71 an und surfe mal mit deinem tv irgendwas an, dann sollte die queue ultrahigh auch ausschlagen.


  • Moderator

    @mike69 said in Traffic Shaping funktioniert nicht so wie es soll.:

    Jens, kannst du Beitrag 5 richtig löschen? Wollte nicht zitieren, nur bearbeiten.

    Klar! wisch und wech! ✋ Du hast nichts gesehen...



  • @m0nji said in Traffic Shaping funktioniert nicht so wie es soll.:

    @mike69
    wieso inbound? netflix macht doch keinen connect zu dir sondern du zu netflix. destination müssten also die netflix server sein und source dein tv.
    gib als source mal die 192.168.2.71 an und surfe mal mit deinem tv irgendwas an, dann sollte die queue ultrahigh auch ausschlagen.

    In den Regeln steht WAN als Interface, habe es so interpretiert wie in den Firewallrules, unter "WAN" da sind die Geräte auch unter "destination" eingetragen. Floating also in Richtung von hier zum Server. Werde es dann testen, danke.

    @JeGr
    Dankeschön👍

    Habe namebench gestern mit den cloudflare DNS-Servern durchlaufen lassen, aber nicht die Zeit gefunden was zu posten. Heute ist die Bude voll, wenn nicht heute, dann morgen. Übrigens, IP 1.1.1.1 war Spitzenreiter. :)



  • Moin.

    Kleines Feedback, dank der Hilfe von @m0nji funktioniert der Traffic Shaper jetzt wie er soll.
    Leider lässt sich Netflix auf dem TV nicht dazu überreden, den richtigen Queue zu nutzen. Mit Youtube auf dem TV funktioniert es. Obwohl die IP des TVs in der Floatingrule eingetragen ist, schafft es das Netflixapp dieses zu umgehen.😕

    edit:
    Der Webbrowser lässt sich auch nicht überreden, den richtigen Queue zu nutzen. Wie geht das?



  • @mike69
    Kannst du uns mal den Inhalt der Floating Rule für den TV zeigen?
    Zusätzlich einfach noch eine Übersicht aller Floating Rules.
    Du hast auf dem Interface WAN und LAN jetzt aber keine Rule mehr mit Queue, ja?!

    Wenn Youtube in die Queue reingeht und Netflix nicht, kann es eigentlich nur noch am Protokoll liegen. Wenn du ANY statt TCP/UDP einstellst, sollte aber auch das damit erschlagen werden. IPV6 nutzt du nicht?



  • Na klar.

    Settings fürs TV:
    0_1528453545740_pfSense.home - Firewall: Rules: Floating: Edit - Mozilla Firefox_040.png

    Hier die Rules:
    0_1528453661766_pfSense.home - Firewall: Rules: Floating - Mozilla Firefox_041.png

    Hier noch der Queue:
    0_1528454725368_pfSense.home - Firewall: Traffic Shaper: By Interface - Mozilla Firefox_042.png

    Wie Du siehst, Protokolle sind auf "any" Auch schon mit TCP/UDP getestet und eine Rule für jedes Protokoll TCP und UDP.
    Seit der All-IP-Umstellung letzten Jahres haben wir IPv6, nutze es aber nicht, zumindest in den Interfaces deaktiviert (none). Die NDP Tabelle ist bis auf den Interfaces leer und unter LAN gibt es keine "IPv6 allow any to LAN" Regel.

    Und wieso der Webbrowser vom LG TV? Aufgefallen ist hier ein kurzer Peak im qUltraHigh beim Starten des Browsers, danach switcht er um auf qDefault im Upload und qLink im Download.



  • Wieso erstellst Du hier eine Floating rule? Auf LAN reicht die Regel völlig. Eventuell muss Du dort auch noch ein Gateway angeben, falls Du mehrere nutzt.



  • @mrsunfire
    oh nein bitte nicht verwirren jetzt.
    Das ist schon völlig in Ordnung wenn er sie als Floating Rule anlegt, dass macht der Wizard auch nicht anders.

    0_1528466134688_7f44a515-4dfa-4664-ae03-d1f634cb4586-image.png

    Es ist sicherlich auch möglich Sie auf das LAN Interface direkt zu legen, jedoch ist es dort auch wieder entscheidend, an welcher Stelle! Ich würde Traffic Shaping Rules immer als Floating Rules anlegen, weil sie halt vor allen anderen Rules abgearbeitet werden.

    Was in seiner Floating Rule nur nicht passt, ist das Interface LAN in diesem Beispiel. Dort muss nur WAN ausgewählt werden. Anders ist es, wenn du es auf dem Interface erstellen willst, dort müsste es in LAN.

    0_1528466565585_e5f47b28-fc95-41e7-ad9e-68068fc19286-image.png

    Wie gesagt, einmal den Wizard durchlaufen lassen und mal nur HTTP dort auswählen und auf higher Priority stellen. Dann hast du eine Beispiel Rule!



  • @m0nji said in Traffic Shaping funktioniert nicht so wie es soll.:

    Was in seiner Floating Rule nur nicht passt, ist das Interface LAN in diesem Beispiel. Dort muss nur WAN ausgewählt werden. Anders ist es, wenn du es auf dem Interface erstellen willst, dort müsste es in LAN.

    Wenn ich LAN in der Rule nicht setze läuft der Download über qLink Queue, ist LAN gesetzt über qUltraHigh im LAN Interface. Möchte ja hauptsächlich den Download priorisieren. Wenn dazu nur WAN reicht, nehme ich das LAN da raus aus der Rule.



  • @mike69 komisch.
    bin kein traffic shaping experte aber habe vorhin zum test den wizard durchlaufen lassen um nur den http traffic zu priorisieren. das hat auch geklappt und in der floating rule waren nur die wan interface markiert.



  • @m0nji said in Traffic Shaping funktioniert nicht so wie es soll.:

    @mike69 komisch.
    bin kein traffic shaping experte aber habe vorhin zum test den wizard durchlaufen lassen um nur den http traffic zu priorisieren. das hat auch geklappt und in der floating rule waren nur die wan interface markiert.

    Ja, da sind wir schon zu zweit. :)

    Experten im deutschen Raum zu diesem Thema sind leider rar gesät. Zumindest könnt ich dank Dir und dem Forum mein Wissen etwas erweitern.
    Da mein Schulenglisch von vor 35 Jahren gerade noch zum Lesen einfacher Literatur reicht und diverse Übersetzungstools doch recht schräg ihren Job machen, habe ich leichte Bedenken die Frage im englischen Traffic Schaper Teil zu stellen.

    Also VoIP über die Fritze klappt sehr gut, bunkert sich der Schaper beim telefonieren gleich 64 kb/s, in beide Richtungen.
    Wenn ein Kumpel per FTP an unserem Server nuckelt wird er bei benötigten Upload geschmeidig abgewürgt, so wie es sein soll. Nur Netflix will nicht mit unserem LG TV, ein kurzer Peak, dann switcht er auf die default Queues.



  • Mal ne Frage an alle. Hat jemand den Traffic Schaper zufriedenstellend zum laufen bekommen?



  • So, noch ein Feedback.

    Dank der Hilfe von @m0nji und ein bissl Try & Error looft das Traffic Shaping so wie es soll. Selbst Netflix läuft über eine PS4 einwandfrei mit dem richtigen Queue, das GästeWLAN wird auch richtig priorisiert, alles Tutti. Nur das TV von LG braut sich sein eigenes Süppchen, da gibt es noch Bedarf.
    Im Grunde ist das Hauptproblem zum Thema TS gelöst, für Netflix over LG TV muß ich woanders eine Lösung suchen oder mach ein anderen Thread auf.

    Danke nochmal an alle.👍 .

    Mike



  • Kann es sein dass der TV bei Dir über IPv6 läuft und Du daher andere Regeln brauchst?



  • @mrsunfire said in [gelöst]Traffic Shaping funktioniert nicht so wie es soll.:

    Kann es sein dass der TV bei Dir über IPv6 läuft und Du daher andere Regeln brauchst?

    Gute Frage, die Idee kam mir auch in den Sinn. Kann aber nicht sein, es gibt nur eine Regel, die IPv4 nach draußen zulässt. IPv6 wird von Hause aus geblockt. Oder LG lässt alles durch die hauseigenen Server via Proxy oder ähnliches laufen, bin da noch ziemlich ratlos. Werde mal die Aktivitäten des TVs loggen.