Solution for Playstation 3 and 4 to address NAT 3 mode

  • Without this fix, PS3/4 will sense a NAT 3 mode which prevents most multiplayer game play and inbound a/v calling. The goal is to get to NAT mode 2 which is full functionality.

    Basically, assign a static IP the Playstation and then change the Firewall / NAT / Outbound mode to Hybrid (from Automatic) and add a single rule for the Playstation to use static ports by checking the box in the custom rule.

    There's a video explaining how to do it:

    Once the config is done then the Playstation switches to NAT mode 2 (the ideal mode).

  • make your game console IP address all static port.

  • @chpalmer Yes but that's tricky unless you statically IP assign the game console. If you, like most people, just have it DHCP then making the f/w static NAT port rule for the DHCP host is tricky.

  • Assign it an IP from the router itself. Static Mapping.

    Or add another interface and make a new subnet which is all static port which is what Ive done here using a /29

  • I tried this configuration and my PS4 is till showing as Type 3.

  • LAYER 8 Global Moderator

    Your going to have a hard time behind a double nat maintaining static ports..

    Napt by its nature changes the source port when you make an outbound connection. This can be overcome with with setting static port in your oubound nat on pfsense. But your router in front of pfsense would also have to maintain this static port..

    Many services in these console games (for some unknown reason like to see static ports) ie connection coming from specific port.. So lets for example say you create an connection to publicIP:80 from privateIP:2000

    Normally with nat (napt) you have this

    privateIP:2000 ---> publicIP:80 (pfsense) YourPublicIP:RandomPort ----> publicIP:80

    To get some of these applications/games to work you have to setup outbound nat to be static so you get this.

    privateIP:2000 ---> publicIP:80 (pfsense) YourPublicIP:2000---> publicIP:80

    If you put a nat device in front you normally get this.

    privateIP:2000 ---> publicIP:80 (pfsense) otherprivateIP:RandomPort ----> publicIP:80 (nat router) YourpublicIP:SomeOtherRandomPort ----> publicIP:80

    What you mignt need to happen is this.

    privateIP:2000 ---> publicIP:80 (pfsense) otherprivateIP:2000 ----> publicIP:80 (nat router) YourpublicIP:2000 ----> publicIP:80

    This is just an example of problem you can have with double nat and such services that for whatever reason want to see some specific sourceport.

    So is pfsense the only thing doing nat? What is your outbound mapping look like?