pfSense zerstört OpenVPN Config



  • Moin,

    ich habe mit meiner pfSense auf der Arbeit ein Problem, mir wird häufig der Zeilenumbruch einer OpenVPN config zerschossen:

    Richtig:

    keepalive 2 40
    link-mtu 1558
    push "route 192.168.0.0 255.255.0.0"
    push "redirect-gateway"
    

    Zerdengelt:

    keepalive 2 40
    link-mtu 1558
    push "route 192.168.0.0 255.255.0.0"push "redirect-gateway"
    

    Nach der Reparatur mittels einmal "Enter" an der richtigen Stelle funktioniert das VPN wieder.
    Es wird nur der erste OpenVPN Server Eintrag zerlegt.

    Habt Ihr eine Idee?

    -teddy



  • Hi,,

    konfigurierst du diese Dinge nach Möglichkeit nicht in der GUI bzw. schreibst du die push Kommandos in die Advanced Options?

    Hätte noch nicht gehört, dass die Konfig der GUI durcheinandergebracht wird.

    Grüße



  • Steht direkt unter dem Fenster der Custom options:

    Enter any additional options to add to the OpenVPN server configuration here, separated by semicolon.



  • moin,

    @viragomann

    ich konfiguriere alles über die GUI, beim direkten Bearbeiten der Config wüsste ich wo der Fehler sitzt 😇

    Gerade nochmal mit einem anderen PC probiert, Browser Firefox, Opera und Konqeuror das Ergebniss: In allen 3 Fällen eine zerdengelte Config, genau wie oben, der letzte Zeilenumbruch wird entfernt.

    -teddy



  • Also ich habe auch 2 OpenVPN Server konfiguriert und beide sehen nach wie vor gut aus.
    Allerdings kannst du probieren, hinter jeder Zeile ein Semikolon zu setzen ";". So habe ich zumindest meine Custome Einträge gesetzt.



  • Moin,

    mit ";" wurde bei einem schnellen Test nichts mehr zersemmelt, danke.


  • Moderator

    Jep, das ist je nach Browser und interpretierter Textarea Textbox beim POST gegen den Webserver wird da manchmal der Zeilenumbruch geschluckt. Deshalb steht das schon (m.W. sehr lange) bei den adv. Options dabei, dass man bitte alle Einträge mit ";" voneinander trennen soll, dann spielen die Newlines keine Rolle :)



  • Moin,

    ja es steht da, ich habe es aber geschafft den Teil mit dem ";" zu ignorieren :-) , die Augen rastetem am Beispiel ein, vielleicht sollte da auch ein ";" hin ;-) .

    -teddy