pfBlockerNG not showing in menus, tried reinstalling



  • I have a firewall with pfSense 2.4.3 and needed to install pfBlockerNG, I went to packages installed the normal pfBlockerNG 2.1.2_3 package and it completed successfully. Go back to the dashboard and click on Firewall at the top, no pfBlockerNG listed. I reboot the firewall, still no pfBlockerNG. I go to packages and click on reinstall, it complete successfully, but no pfBlockerNG.

    I update to 2.4.3_1, nothing. I uninstall the package, reboot and then reinstall - nothing.

    I change my update to development and install the new 2.2 pfBlocker - still nothing!

    I just tried to install it on ANOTHER 2.4.3_1 firewall and no listing shows up. I think there is a bug batman.

    EDIT: If I go direct to /pkg_edit.php?xml=pfblockerng.xml I can get to it - but the shortcut doesn't show. I've gone to the console and restarted PHP and the webconfig.

    When I try to save though the button redirects to https://pkg_edit.php/?xml=pfblockerng.xml so it's nearly impossible to configure.



  • I just tried to edit more stuff and I got an error:0_1528816617019_bdi_pfblockerng_bug.PNG




  • Rebel Alliance Global Moderator

    I just installed it... Not seeing any problems running 2.4.3p1

    >>> Installing pfSense-pkg-pfBlockerNG... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 9 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-pfBlockerNG: 2.1.2_3 [pfSense]
    	lighttpd: 1.4.48_1 [pfSense]
    	lua52: 5.2.4 [pfSense]
    	whois: 5.2.17 [pfSense]
    	GeoIP: 1.6.11 [pfSense]
    	grepcidr: 2.0 [pfSense]
    	aggregate: 1.6_1 [pfSense]
    	pecl-intl: 3.0.0_11 [pfSense]
    	icu: 60.2_1,1 [pfSense]
    
    Number of packages to be installed: 9
    
    The process will require 49 MiB more space.
    10 MiB to be downloaded.
    [1/9] Fetching pfSense-pkg-pfBlockerNG-2.1.2_3.txz: .......... done
    [2/9] Fetching lighttpd-1.4.48_1.txz: .......... done
    [3/9] Fetching lua52-5.2.4.txz: .......... done
    [4/9] Fetching whois-5.2.17.txz: ........ done
    [5/9] Fetching GeoIP-1.6.11.txz: .......... done
    [6/9] Fetching grepcidr-2.0.txz: ... done
    [7/9] Fetching aggregate-1.6_1.txz: .. done
    [8/9] Fetching pecl-intl-3.0.0_11.txz: .......... done
    [9/9] Fetching icu-60.2_1,1.txz: .......... done
    Checking integrity... done (0 conflicting)
    [1/9] Installing lua52-5.2.4...
    [1/9] Extracting lua52-5.2.4: ......... done
    [2/9] Installing icu-60.2_1,1...
    [2/9] Extracting icu-60.2_1,1: .......... done
    [3/9] Installing lighttpd-1.4.48_1...
    ===> Creating groups.
    Using existing group 'www'.
    ===> Creating users
    Using existing user 'www'.
    [3/9] Extracting lighttpd-1.4.48_1: .......... done
    [4/9] Installing whois-5.2.17...
    [4/9] Extracting whois-5.2.17: .......... done
    [5/9] Installing GeoIP-1.6.11...
    [5/9] Extracting GeoIP-1.6.11: .......... done
    [6/9] Installing grepcidr-2.0...
    [6/9] Extracting grepcidr-2.0: ..... done
    [7/9] Installing aggregate-1.6_1...
    [7/9] Extracting aggregate-1.6_1: .... done
    [8/9] Installing pecl-intl-3.0.0_11...
    [8/9] Extracting pecl-intl-3.0.0_11: .......... done
    [9/9] Installing pfSense-pkg-pfBlockerNG-2.1.2_3...
    Extracting pfSense-pkg-pfBlockerNG-2.1.2_3: .......... done
    Saving updated package information...
    done.
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...
    Downloading MaxMind GeoIP databases. This may take a minute...
     GeoIP.dat... done.
     GeoIPv6.dat... done.
     GeoLite2-Country-CSV.zip... done.
    Downloading MaxMind GeoIP databases... done.
    Converting MaxMind GeoIP databases for pfBlockerNG.
     This may take a few minutes...
    Country code update Start [ 06/12/18 10:39:01 ]
     Converting MaxMind Country databases for pfBlockerNG.
     Processing ISO IPv4 Continent/Country Data
     Processing ISO IPv6 Continent/Country Data [ 06/12/18 10:39:32 ]
    Creating pfBlockerNG Continent XML files...
     Creating pfBlockerNG Continent XML files
     IPv4 Africa			 [ 06/12/18 10:39:40 ]
     IPv6 Africa			 [ 06/12/18 10:39:41 ]
     IPv4 Antarctica		
     IPv6 Antarctica		
     IPv4 Asia			
     IPv6 Asia			 [ 06/12/18 10:39:44 ]
     IPv4 Europe			 [ 06/12/18 10:39:45 ]
     IPv6 Europe			 [ 06/12/18 10:39:56 ]
     IPv4 North America		 [ 06/12/18 10:40:00 ]
     IPv6 North America		 [ 06/12/18 10:40:08 ]
     IPv4 Oceania			 [ 06/12/18 10:40:09 ]
     IPv6 Oceania			 [ 06/12/18 10:40:10 ]
     IPv4 South America		
     IPv6 South America		 [ 06/12/18 10:40:11 ]
     IPv4 Proxy and Satellite	
     IPv6 Proxy and Satellite	 [ 06/12/18 10:40:12 ]
     IPv4 TOP 20			
     IPv6 TOP 20			
     pfBlockerNG Reputation Tab
    Country Code Update Ended
    
    Adding pfBlockerNG Widget to the Dashboard... done.
    Remove any existing and create link for DNSBL lighttpd executable... done.
    Creating DNSBL web server start-up script... done.
    Upgrading Adv. Inbound firewall rule settings ... no changes required ... done.
    Custom commands completed ... done.
    Executing custom_php_resync_config_command()...done.
    Menu items... done.
    Services... done.
    Writing configuration... done.
    Message from lua52-5.2.4:
    
    ===>   NOTICE:
    
    The lua52 port currently does not have a maintainer. As a result, it is
    more likely to have unresolved issues, not be up-to-date, or even be removed in
    the future. To volunteer to maintain this port, please create an issue at:
    
    https://bugs.freebsd.org/bugzilla
    
    More information about port maintainership is available at:
    
    https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
    Message from GeoIP-1.6.11:
    
    GeoIP does not ship with the actual data files. You must download
    them yourself! Please run:
    # /usr/local/bin/geoipupdate.sh
    >>> Cleaning up cache... done.
    Success
    

    0_1528818272599_pfblocker.png



  • How would I reinstall pkg_edit.php?

    I am getting it intermittently, I have 48 pfsense firewalls.

    I first noticed it on my home firewall when 2.4.3 was just released, probably the Saturday after, my kids were yelling they had no internet, pfblocker stopped allowing all traffic, so I disabled it and it worked, so I updated to 2.4.3 and the pfblocker entry was gone, so I tried re-installing no dice, so I just removed it and went about my day. It's my home firewall, my only open ports are SSLVPN and Plex.

    Then yesterday, I was fixing a client's mailserver, they had an accounting email that kept getting locked out. Well the mailserver was blocking password guessing attempts from china/india and amsterdam. That's when I went to install pfblockerng and it didn't work. I futzed around with it.
    Then today I went on to my office firewall and installed pfblocker and it also did not add the link.

    However not a week or two ago, I had set up no issues pfblocker on 3 other firewalls.

    They are all at 2.4.3 non p1 (except for a few) and I centrally manage them, so I have cron also installed. Also on most of the firewalls I have openvpn-client-export.

    0_1528827648580_bdi_pfblockerng_installedpackages.PNG

    0_1528827710007_bdi_pfblockerng_nopf.PNG

    I just did it on another firewall:

    >>> Installing pfSense-pkg-pfBlockerNG... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 9 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-pfBlockerNG: 2.1.2_3 [pfSense]
    	lighttpd: 1.4.48_1 [pfSense]
    	lua52: 5.2.4 [pfSense]
    	whois: 5.2.17 [pfSense]
    	GeoIP: 1.6.11 [pfSense]
    	grepcidr: 2.0 [pfSense]
    	aggregate: 1.6_1 [pfSense]
    	pecl-intl: 3.0.0_11 [pfSense]
    	icu: 60.2_1,1 [pfSense]
    
    Number of packages to be installed: 9
    
    The process will require 49 MiB more space.
    10 MiB to be downloaded.
    [1/9] Fetching pfSense-pkg-pfBlockerNG-2.1.2_3.txz: .......... done
    [2/9] Fetching lighttpd-1.4.48_1.txz: .......... done
    [3/9] Fetching lua52-5.2.4.txz: .......... done
    [4/9] Fetching whois-5.2.17.txz: ........ done
    [5/9] Fetching GeoIP-1.6.11.txz: .......... done
    [6/9] Fetching grepcidr-2.0.txz: ... done
    [7/9] Fetching aggregate-1.6_1.txz: .. done
    [8/9] Fetching pecl-intl-3.0.0_11.txz: .......... done
    [9/9] Fetching icu-60.2_1,1.txz: .......... done
    Checking integrity... done (0 conflicting)
    [1/9] Installing lua52-5.2.4...
    [1/9] Extracting lua52-5.2.4: ......... done
    [2/9] Installing icu-60.2_1,1...
    [2/9] Extracting icu-60.2_1,1: .......... done
    [3/9] Installing lighttpd-1.4.48_1...
    ===> Creating groups.
    Using existing group 'www'.
    ===> Creating users
    Using existing user 'www'.
    [3/9] Extracting lighttpd-1.4.48_1: .......... done
    [4/9] Installing whois-5.2.17...
    [4/9] Extracting whois-5.2.17: .......... done
    [5/9] Installing GeoIP-1.6.11...
    [5/9] Extracting GeoIP-1.6.11: .......... done
    [6/9] Installing grepcidr-2.0...
    [6/9] Extracting grepcidr-2.0: ..... done
    [7/9] Installing aggregate-1.6_1...
    [7/9] Extracting aggregate-1.6_1: .... done
    [8/9] Installing pecl-intl-3.0.0_11...
    [8/9] Extracting pecl-intl-3.0.0_11: .......... done
    [9/9] Installing pfSense-pkg-pfBlockerNG-2.1.2_3...
    Extracting pfSense-pkg-pfBlockerNG-2.1.2_3: .......... done
    Saving updated package information...
    done.
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...
    Downloading MaxMind GeoIP databases. This may take a minute...
     GeoIP.dat... done.
     GeoIPv6.dat... done.
     GeoLite2-Country-CSV.zip... done.
    Downloading MaxMind GeoIP databases... done.
    Converting MaxMind GeoIP databases for pfBlockerNG.
     This may take a few minutes...
    Country code update Start [ 06/12/18 14:24:18 ]
     Converting MaxMind Country databases for pfBlockerNG.
     Processing ISO IPv4 Continent/Country Data
     Processing ISO IPv6 Continent/Country Data [ 06/12/18 14:24:49 ]
    Creating pfBlockerNG Continent XML files...
     Creating pfBlockerNG Continent XML files
     IPv4 Africa			 [ 06/12/18 14:24:58 ]
     IPv6 Africa			
     IPv4 Antarctica		
     IPv6 Antarctica		
     IPv4 Asia			
     IPv6 Asia			 [ 06/12/18 14:25:02 ]
     IPv4 Europe			
    Message from lua52-5.2.4:
    
    ===>   NOTICE:
    
    The lua52 port currently does not have a maintainer. As a result, it is
    more likely to have unresolved issues, not be up-to-date, or even be removed in
    the future. To volunteer to maintain this port, please create an issue at:
    
    https://bugs.freebsd.org/bugzilla
    
    More information about port maintainership is available at:
    
    https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
    Message from GeoIP-1.6.11:
    
    GeoIP does not ship with the actual data files. You must download
    them yourself! Please run:
    # /usr/local/bin/geoipupdate.sh
    >>> Cleaning up cache... done.
    Success
    

    0_1528828031148_pfblockernotworkyworky.PNG





  • Check your config.xml, maybe something is breaking the installation.



  • I hope I sanitized this properly.... But no, nothing jumps out on the config.xml

    0_1528834778798_config-foo.xml



  • @meeleikon You don't have a

    <installedpackages>
    

    section 🤔

    But you have some pfblockerNG cron jobs!
    So something is broken in your config.xml
    Can you install any package ? Like Cron or System_Patches ?



  • All other packages work fine. Literally just pfblocker and on a few firewalls all different configs. Only similarity is cron and openvpn.

    0_1528922513568_installedpackages-config-foo.xml



  • Those packages were probably installed before pfblockerNG.

    Do you have <installedpackages> sections on your other firewalls?

    Now if you try to install a package you didn't have installed, does the installation proceed ?



  • I was just able to install system patches and I can see it's shortcut under system and it's page opens.

    My home firewall was also having an issue, I may try a reload and install pfblocker before cron and see what that does.



  • Maybe inspect Diagnostics / Backup & Restore / Config History to see what happened in the past with the config.


  • Rebel Alliance Global Moderator

    Just so you know I had cron installed and am using it before I installed the pfblocker package.


  • Moderator

    Run the following command:

    grep -A30 "<menu" /conf/config.xml
    

    And check to see if there is an empty <menu></menu> tag... I have seen this with another user, but am not sure if its a pfSense bug or a pfBlockerNG bug?

    If there is an empty tag, you can edit /conf/config.xml and remove that empty tag. If you do that from pfSense > Edit File, that will reload the config after you press save and hopefully that fixes it.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy