Can't boot in latest june 12 snapshot



  • I can’t boot, stuck at starting dns resolver.


  • Rebel Alliance Developer Netgate

    That sounds like it’s booting to me, but failing someplace later. “Can’t boot” implies the OS doesn’t even start. I have updated a couple VMs and hardware devices to the latest snapshot and so far they all can boot up all the way.

    Does the DNS resolver say “done” and it stops at the next line, or does it stop in the middle of that? Anything else on the console or in the logs that you can see? What shows up if you press ctrl-t?

    If it stops in the middle of that, then it’s probably something in your DNS resolver config, or a package that hooks into it like pfblocker.

    If it stops just after, then it’s trying to sync user accounts which could be a different problem.



  • @jimp It does not say done, just gets stuck at “…” I do have pfblockerng-devel installed with lots of dnsbl feeds enabled but they worked fine on previous snapshot.


  • Rebel Alliance Developer Netgate

    Even if they worked on previous snapshots, that is what I would focus on since it is the most likely culprit, and it’s possible something that changed in pfBlocker or one of its updated files is causing or contributed to the failure on your firewall.

    You might press ctrl-c and from the shell try to check out the system and resolver logs (e.g. /usr/local/sbin/clog /var/log/resolver.log) and see if there is any more detail there.



  • @jimp so strange, it works perfectly now. I made sure that I reloaded all the feeds in pfblockerng before upgrading this time, there was a dnsbl database error last time I tried to upgrade because when I reboot (i emailed bbcan about this) the database gets wiped and I have to reload it as I am using ramdisk. I went back to june 7 snapshot (newer snapshot memstick iso won’t boot in esxi 6.7, I saw some commit changes you made to how iso files work on github so I went with june 7 snapshot) and I can’t do snapshots in esxi as I am using zfs and had to put the disk in physical raw disk mode.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy