OpenVPN - access LAN hosts with FQDN



  • So, done some digging on the forum and I can't find out what happens here...

    I have my pfSense running smoothly with all devices neatly registering their hostnames in the DHCP. From LAN I can access those devices just by using the FQDN.

    I set up OpenVPN and force all traffic through the VPN. Can access the web, works fine. Can access any device on the LAN by using IP, all fine, but I cannot access them with their FQDN...

    I assume it's a DNS issue but cannot figure out why... Anybody have any ideas?

    Thanks a ton in advance!
    B.



  • Would anyone have any ideas? I'm still stuck...



  • @bdeprez said in OpenVPN - access LAN hosts with FQDN:

    I'm still stuck...

    Yeah, after more than 2 years you would be. 😉

    When you're on the LAN you get your address from the DHCP server and the associated address have host names. When you're on a VPN, then the IP address comes from the VPN, not the server, breaking any connection between IP address and host name.



  • @JKnott While what you said holds,I think the op cant resolve lan devices by fqdn.
    If thats the case, then openvpn server isnt pushing lan dns server to clients, which is a simple setting.



  • @netblues

    It probably is pushing the DNS, but the address has changed so it provides what's now the wrong address. The host or nslookup command should show what address is assigned to the host name. I bet it's the LAN address, not the VPN address for that device.



  • @JKnott @netblues - thank you so much for jumping in

    The issue I had was basically that I was able to connect from the internet over the vpn to my home network but I was not able to reach any LAN devices by using their hostname, only IP.

    I basically removed the entire OpenVPN setup and started from scratch (also since I in the meantime moved to a dual WAN setup). I also updated the firmware of my SG-3100. Now everything works as expected - perhaps something was wrong in my config (I reconfigured using the Wizard) or perhaps the reboot of the pfSense box did the trick... I truly don’t know... But I’m happy it works now!


Log in to reply