Logrotate para squid3



  • Quiero rotar el access.log de mi squid por meses en la configuracion aparece rotarlos por dias pero eso no me sirve porque no todos los meses tienen la misma cantidad de dias.

    En esta direccion cree un archivo llamado squid y dentro de este lo siguiente /usr/local/etc/logrotate.d

    /var/squid/logs/*.log {
    monthly
    compress
    delaycompress
    missingok
    nocreate
    sharedscripts
    postrotate
    test ! -e /var/run/squid/squid.pid || /usr/local/sbin/squid -k rotate
    endscript
    }
    Pero no funciona

    Evidentemente algo me falta o hago mal

    Que me sugieren

    Saludos



  • Pero el squid ya tiene esa funcion en el squid general...



  • El squid permite rotarlos por cantidad de dias y no por meses y estos no tienen la misma cantidad de dias.



  • Creo q no es buena practica dejar un log del squid por meses, el archivo puede ser muy grande y puede afectar el cache del squid si se almancena en el mismo disco



  • respeto su criterio pero esto lo he tenido por un tiempo funcionando en debian sin problemas lo que pasa es que quiero tenerlo en pfsense por un problema de humanizar el trabajo, en fin lo que quiero es darle solución a esa interrogante.
    Saludos



  • Debian es Debian y pfsense es pfsense. Lo digo en base a que he trabajado squid en ambas plataforma.

    Que pasa con el rotate diario? es ideal para las estadísticas, de esta forma el query de construcción lo hace mucho mas rápido. Te recomiendo que tu access log rote de forma diaria, de esta forma a la hora de las estadísticas la construcción va contra el dia anterior.
    Al parecer tu configuración esta bien, solo debes probarla de forma manual a ver si funciona. logrotate -f ......... archivo conf.

    saludos.



  • Ok gracias por su tiempo y lo tendre en cuenta, de todas formas lo hice por consola y si funciona.



  • Leyendo tu post con mas calma.

    Veo que dices que "creaste el archivo: /usr/local/etc/logrotate.d/squid"

    Por lo que se me ocurre que alguien por defecto te esta matando dicha configuración y es la que debes tener en el /etc/crontab esta tarea

    0 0 * * * root /usr/local/sbin/squid -k rotate -f /usr/local/etc/squid/squid.conf

    Estoy viendo donde podrá estar el asunto, ya que el rotate del cron es propio del squid, fijate que hace referencia al squid.conf y el squid.conf tiene su propio rotate

    logfile_rotate 1

    El cual es el que defines en la configuración del squid a nivel web en el panel del pfsense.

    Creo que tu solucion es dejar la rotacion en blanco, ya que dice esto:

    Defines how many days of logfiles will be kept. Rotation is disabled if left empty.

    y alli deberia entrar en acción el tuyo siempre y cuando exista el proceso que es llamado mediante el cron.

    Saludos.


Log in to reply