(gelöst) Kein VPN bei WLAN aber bei GSM-Verbindung



  • Servus,

    neues Projekt, neues Problem :D
    Habe soeben mir eine VPN Verbindung mit IPSEC eingerichtet.
    Diese Funktioniert allerdings nur zur Hälfte.

    Gehe ich ganz normal über mein iPhone, über GSM ins Netz, wird die VPN Verbindung aufgebaut und ich kann auch auf mein Netzwerk zugreifen.
    Baue ich die Verbindung allerdings in meinem WLAN auf, bekomme ich keine Verbindung.
    Auch wenn ich alles in den Regeln zulasse.

    Woran könnte das liegen?
    Und das andere, wenn ich eine Verbindung habe, bekomme ich leider keinen DNS zugewiesen.
    Muss alle IP Adressen Manuell eingeben, was etwas doof ist.
    Kennt hier einer vielleicht Abhilfe?

    Danke im Voraus



  • Hallo,

    wenn Du nicht "von außen" kommst, dann kommst Du auch nicht auf dem Interface an, welches die Konfiguration für den Tunnel hat. Selbst wenn Du Deine externe Adresse (z.B. via DynDNS) verwendest, könnte es sein, dass z.B. die Fritzbox nicht erst "rausgeht und dann wieder reinkommt", sondern intern bleibt. Erklärung gerne von den Spezialisten :-)

    Bzgl. des DNS-Problems habe ich schon mal eine Beschreibung gesehen hier im Forum gelesen, die ich aber auch gerade icht zur Hand habe.

    Viele Grüße
    Jörg



  • @jma791187 said in Kein VPN bei WLAN aber bei GSM-Verbindung:

    Hallo,

    wenn Du nicht "von außen" kommst, dann kommst Du auch nicht auf dem Interface an, welches die Konfiguration für den Tunnel hat. Selbst wenn Du Deine externe Adresse (z.B. via DynDNS) verwendest, könnte es sein, dass z.B. die Fritzbox nicht erst "rausgeht und dann wieder reinkommt", sondern intern bleibt. Erklärung gerne von den Spezialisten :-)

    Das macht Sinn und scheint auch der Fehler zu sein, mache ich einen Hotspot auf und versuche darüber zu Verbinden bin ich auch einen Schritt weiter.
    Nun sagt Win10 allerdings, "IKE-Authentifizierung-Anmeldeinformationen sind nicht akzeptabel" o.O

    Habe mich an diese Anleitung gehalten:
    https://www.administrator.de/wissen/ipsec-vpn-mobile-benutzer-pfsense-firewall-einrichten-337198.html

    Im Serverzertifikat habe ich den Domain Namen mit eingetragen und auch die IP Adresse.
    Verbindung kommt auch bis an die pfSense an und wird dann abgelehnt.
    Woran könnte es liegen?

    UPDATE 21:08Uhr

    Wenn ich auf meinem Rechner TheGreenBow als VPN Client nutze läuft alles wunderbar.
    DNS funzt und Verbindung läuft super, allerdings würde ich gerne vermeiden 70€ für diese Software ausgeben zu müssen.
    Wäre super wenn mir jemand bei dem Einrichten der Hauseigenen Win10 VPN helfen könnte :)



  • Kurze Info,

    bei OpenVPN kann man als Interface "Localhost" angeben. Damit lauscht die Sense auf allen Interfaces. Man muss nur den Port für die gewollten Interfaces öffnen und schon funktioniert alles. Hatte bisher echt kaum Sorgen. DNS klappt damit auch besser bei IOS Geräten, als mit IPSEC. Habe bisher nie DNS über IPSEC mit IOS Geräten hinbekommen.

    Wenn du bei IPSEC bleiben willst, kannst du den Shrew Soft VPN Client nehmen.



  • Servus,

    Danke für den Tipp mit OpenVPN!
    Nach Startschwierigkeiten ist nun alles soweit eingerichtet, dass ich von meinem Handy und Laptop über GSM/LTE einen Tunnel aufbauen kann.
    DNS läuft auch auf beiden Geräten super!
    Ich Danke mal wieder für die spitzen Hilfe, hat mir 70€ erspart :D


Log in to reply