To apply firewall rules it is required a reboot always? #Latest_Release



  • Hello all,

    So, I've been using pfsense from last two months not much families but i worked on it quite a lot.

    Now, whenever i set/change any firewall rules it always require a reboot to take place. I searched online and people suggested couple of option and it worked for them but not for me.

    Here are the test cases which i tried to apply firewall rules ASAP without rebooting pfsense.

    Test1: Removing config.cache and re initializing
    Commands: 1: rm /tmp/config.cache 2: /etc/rc.filter_configure (Also tried with /etc/rc.filter_configure_sync)
    Result: Not worked!!

    Test2: Reset All the state:
    Diagnostics --> States --> Reset States --> Reset
    Result: Not worked!!

    The only way to make sure that rule should work asap to reboot the pfsense :|

    Please help. It is really annoying to reboot a pfsense whenever i change or add rule.

    Thanks in advance!!



  • You never have to reboot for fw rules.
    Rebooting does nothing.

    Resetting states is all that is needed (sometimes)

    What are you trying Todo exactly.... Specifics are important



  • I am running 15 computers behind pfsense and i haven't allowed internet connection to any PC.
    In my setup sometimes i need to allow internet connection to perform couple of activity. And, after as soon as i apply the rule to turn it on/off everytime i need to reboot the system. (And this will disturb entire network for couple of minutes because all are connected to each other :| ) I tried States reset but not worked!! Not sure what i am missing or making a mistake.


  • Rebel Alliance Global Moderator

    So you mean your port forwarding into this PC, or your allowing this pc to use the internet?

    Please post up you rules, and then the rule you put in to allow, and then remove/disable. And then how your clearing the states.

    Example if you allow PC at 192.168.1.100 to use the internet with an any any rule with 192.168.1.100 as source. Now your done - remove/disable that rule. Then go into your states and look for all states with 192.168.1.100 and clear them.



  • @johnpoz Haah! Thanks mate it worked!! :D Phew!!