OpenVPN Client: Packet Loss



  • I am running 2.4.3. Vanilla PfSense box with the exception of DHCP reservation and a remote access OpenVPN server.

    I set up PIA OpenVPN Client using this guide.

    I made sure to NAT > Outbound > Manual and copy all of the existing rules, but switch the interface to OpenVPN.

    I am getting intermittent packet loss when the Client is enabled. I can ping from the WAN interface, but the ping fails from the LAN interface (and clients on the LAN).

    OpenVPN client shows "Up". When I can resolve a webpage successful, IP Chicken shows my IP to be the PIA Server IP.

    When I disable the OpenVPN client, the symptoms disappear.

    I have tried rebooting the PfSense Box (several times).

    Anybody have any ideas? I'm pretty ignorant so I am not sure which logs would be the most helpful here.



  • @oguruma In my experience it's not at all uncommon to experience transient packet loss with VPN providers. But is this something that's persistent? What does the quality monitoring for your VPN interface(s) look like (Status > Monitoring, click the wrench, set Left Axis Category to Quality and Graph to your VPN interface)? Have you tried multiple PIA VPN servers?



  • It's a very persistent problem when the OpenVPN client is enabled and the network is essentially rendered unusable.

    If I enable the Client right now, I might make it 5 minutes without issue, then I start getting packet loss. Then I will get 100% packet loss for 5 minutes, then no packet loss, ad nauseam.



  • @oguruma I don't know what would be causing that. Is the packet loss on the VPN client interface(s) only? It would be even more confusing if establishing a VPN client connection provoked packet loss on your WAN interface. Also, have you tried specifying different monitor IPs for your VPN client interface(s)? I use Google and Cloudflare DNS servers (e.g. 8.8.8.8, 1.1.1.1).


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy