nginx: (40: Message too long)



  • Good day i have a problem my squid stop randomly and in system logs i have this nginx: 2018/07/05 12:07:59 [alert] 34137#100109: send() failed (40: Message too long)



  • i think its two set of problem... anyone? help


  • Rebel Alliance Developer Netgate

    We hit this the other day with a customer. Despite not having any configuration to do so, squid is attempting to hit the firewall on port 80 for some reason. Perhaps a client asked for it directly.

    By default the GUI tries to redirect clients from 80 to 443, but this little redirector apparently does not like what squid is trying to send it. Disable the redirect at System > Advanced, Admin Access tab, check Disable webConfigurator redirect rule.



  • i'll give it a try.. thanks