PPPoE broken?



  • I'm on 2.4.4-DEV and I seem to be unable to establish a PPPoE connection. Is it just me or it's broken?

    I'm using a A2SDi-4C-HLN4F that has an Atom C3558 on it. Maybe it's related to the nic driver?


  • Rebel Alliance Developer Netgate

    Was this working before on an older snapshot and then broke, or is this a new setup?

    Is the PPPoE connection on the NIC directly or on a VLAN?

    I can say that PPPoE is not broken in general on 2.4.4. It works for me on my edge firewall and in my lab. That said, there is a known issue with PPPoE on VLANs.



  • This is a new setup. I tried with both VLAN and no VLAN. When I tried without a VLAN I obviously went through my ISP modem that was set in bridge mode. When in this mode I could see the ppp profile name going though but not connecting. When using the VLAN and bypass the modem and connected my pfSense directly in the optical network termination (ONT), then I wasn't seeing the ppp profile name in the log as per the known bug.

    Is it possible that certain nic driver aren't able to process pppoe authentication? Especially since my nic is only barely supported, only the dev version 2.4.4 has the driver for my nic and already I have something not working with it (traffic shapper), maybe pppoe is also broken in the driver?


  • Rebel Alliance Developer Netgate

    That isn't generally the case. I can't say it's impossible that it's related to the driver, but I'm not aware of that ever happening before.

    Does the same configuration work on different hardware?



  • This is my next step. I had to leave the router in place to have a working setup, but I'll try to test an other hardware to see if I can make it work and eliminate my pfSense hardware.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy