PHP Warning: Illegal string offset 'vip' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 1128



  • Hello,

    following the update today, I have this error :

    --
    amd64
    11.2-RELEASE
    FreeBSD 11.2-RELEASE #35 79c8a561b61(RELENG_2_4_4): Mon Jul 9 16:25:18 EDT 2018 root@buildbot3:/builder/ce-master/tmp/obj/builder/ce-master/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [10-Jul-2018 12:25:12 Europe/Paris] PHP Warning: Illegal string offset 'vip' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 1128

    --

    Crash report begins. Anonymous machine information:

    amd64
    11.2-RELEASE
    FreeBSD 11.2-RELEASE #35 79c8a561b61(RELENG_2_4_4): Mon Jul 9 16:25:18 EDT 2018 root@buildbot3:/builder/ce-master/tmp/obj/builder/ce-master/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [10-Jul-2018 12:43:45 Europe/Paris] PHP Warning: Use of undefined constant pfb_status - assumed 'pfb_status' (this will throw an Error in a future version of PHP) in /usr/local/www/pfblockerng/pfblockerng_update.php on line 385
    [10-Jul-2018 12:43:45 Europe/Paris] PHP Warning: Use of undefined constant pfb_output - assumed 'pfb_output' (this will throw an Error in a future version of PHP) in /usr/local/www/pfblockerng/pfblockerng_update.php on line 392
    [10-Jul-2018 12:43:48 Europe/Paris] PHP Warning: Use of undefined constant pfb_status - assumed 'pfb_status' (this will throw an Error in a future version of PHP) in /usr/local/www/pfblockerng/pfblockerng_update.php on line 385
    [10-Jul-2018 12:43:48 Europe/Paris] PHP Warning: Use of undefined constant pfb_output - assumed 'pfb_output' (this will throw an Error in a future version of PHP) in /usr/local/www/pfblockerng/pfblockerng_update.php on line 392
    [10-Jul-2018 12:44:03 Europe/Paris] PHP Warning: Illegal string offset 'vip' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 1128
    [10-Jul-2018 12:44:03 Europe/Paris] PHP Warning: Illegal string offset 'vtype' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 6320
    [10-Jul-2018 12:44:03 Europe/Paris] PHP Warning: Illegal string offset 'key' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 6321

    No FreeBSD crash data found.

    Thank for the helps

    fred



  • 0_1531220442804_8ddd6163-ae26-4347-b05a-794e54e131d4-image.png


  • Moderator

    @fredlubrano said in PHP Warning: Illegal string offset 'vip' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 1128:

    amd64
    11.2-RELEASE
    FreeBSD 11.2-RELEASE #35 79c8a561b61(RELENG_2_4_4): Mon Jul 9 16:25:18 EDT 2018 root@buildbot3:/builder/ce-master/tmp/obj/builder/ce-master/tmp/FreeBSD-src/sys/pfSense

    In pfSense 2.4.4, it moves to PHP v7 which changed how arrays are defined. Unfortunately, you will need to drop down a lower pfSense version until the package is reworked to address the new changes in PHP7.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy