Not receiving ip addresses from VLAN



  • So I have a pfsence box sending vlan 40 into port 1 on a Netgear Prosafe gs728tp.
    0_1531605827184_netgear.JPG
    It is then sent into my unify routers on ports 22 and 24.0_1531606141582_unify.JPG
    but when I try to connect with it on my phone or laptop they say that they failed to obtain an ip.
    here is my vlan config
    0_1531606569404_vlan1.JPG
    and here is my vlan rules
    0_1531606592225_Vlan Rules.JPG
    I can use the wlan if I am not using the vlan.



  • My unifi WAPS use a tagged Trunk port on my Cisco Switches. Try tagging the port that your unifi is plugged into. The Trunk port back to the PFSense box will also need to be VLan tagged.

    Did you also remember to turn on the DHCP server for that VLan, and double check the interface your VLan resides on, specifically look for the MAC address. I had the wrong MAC on mine, I have a 4 port HP Nic in my PFsense Server and the ports are not in the order I thought they should be.



  • Looks like you use VLAN40 configured on all of your equipment. The switch ports connected will need to be tagged entirely. Only if some equipment (like a PC) needs to connect to that VLAN the switch port is configured untagged and the switch adds the tag bit to the packets.


  • Rebel Alliance Global Moderator

    If you want to use vlan 40 on some ssid the ports 22 and 24 would be TAGGED..

    If you just want any wifi client connected to this ssid to be on the native untagged network connected to that switch port then you wouldn't set vlan ID on the ssid.