OpenVPN Client --> PIA very slow



  • My OpenVPN client on pfSense has been working fine for years, but all of the sudden it slowed down to only allowing traffic at 2 megabits per second. I have been trying things to get it to speed up but have found nothing helps.

    Here are the logs that are constantly getting spammed in my OpenVPN logs. Does anyone have any idea what could be going on?

    Jul 16 07:49:08	openvpn	57826	UDPv4 WRITE [101] to [AF_INET]91.207.175.43:1198: P_DATA_V1 kid=0 DATA a07aa1e9 45e04d3a 02b47a95 b2c3acc5 4a9580a3 e6018f5d c45a12dd b142960[more...]
    Jul 16 07:49:08	openvpn	57826	PO_WAIT[0,0] fd=5 rev=0x00000004 rwflags=0x0002 arg=0x006a14d0
    Jul 16 07:49:08	openvpn	57826	I/O WAIT Tr|Tw|SR|SW [2/96600]
    Jul 16 07:49:08	openvpn	57826	PO_CTL rwflags=0x0001 ev=4 arg=0x006a0338
    Jul 16 07:49:08	openvpn	57826	PO_CTL rwflags=0x0000 ev=6 arg=0x006a0334
    Jul 16 07:49:08	openvpn	57826	ENCRYPT FROM: 00002247 fa450000 34266340 0040064b f10a180a 065bbd58 957d9500 50afc00[more...]
    Jul 16 07:49:08	openvpn	57826	ENCRYPT IV: e6018f5d c45a12dd b142960f e8677285
    Jul 16 07:49:08	openvpn	57826	TUN READ [52]
    Jul 16 07:49:08	openvpn	57826	read from TUN/TAP returned 52
    Jul 16 07:49:08	openvpn	57826	I/O WAIT status=0x0004
    Jul 16 07:49:08	openvpn	57826	event_wait returned 1
    Jul 16 07:49:08	openvpn	57826	PO_WAIT[1,0] fd=6 rev=0x00000001 rwflags=0x0001 arg=0x006a0334
    Jul 16 07:49:08	openvpn	57826	I/O WAIT TR|Tw|SR|Sw [2/96600]
    Jul 16 07:49:08	openvpn	57826	PO_CTL rwflags=0x0001 ev=4 arg=0x006a0338
    Jul 16 07:49:08	openvpn	57826	PO_CTL rwflags=0x0001 ev=6 arg=0x006a0334
    Jul 16 07:49:08	openvpn	57826	PO_CTL rwflags=0x0001 ev=5 arg=0x006a14d0
    Jul 16 07:49:08	openvpn	57826	UDPv4 write returned 101
    Jul 16 07:49:08	openvpn	57826	PO_WAIT[0,0] fd=5 rev=0x00000004 rwflags=0x0002 arg=0x006a14d0
    Jul 16 07:49:08	openvpn	57826	PO_CTL rwflags=0x0001 ev=4 arg=0x006a0338
    Jul 16 07:49:08	openvpn	57826	tls_prepend_opcode_v1
    Jul 16 07:49:08	openvpn	57826	ENCRYPT HMAC: bc6a9b53 da9d4590 4fc42569 6340879e 20f7cfcb
    Jul 16 07:49:08	openvpn	57826	PO_WAIT[1,0] fd=6 rev=0x00000001 rwflags=0x0001 arg=0x006a0334
    Jul 16 07:49:08	openvpn	57826	PO_CTL rwflags=0x0001 ev=6 arg=0x006a0334
    Jul 16 07:49:08	openvpn	57826	UDPv4 write returned 101
    


  • Well, looks like i resolved it! It was the logging level of the system. Now it's fast again...sorry for the unneccesary thread.