failed install pfBlockerNG-devel: 2.2.1 on pfSense-2.4.4.a.20180717.0730



  • Hi -

    I had been running on pfSense 2.4.3 stable branch for long time, decided to switch to 2.4.4 development to try new version of pfBlockerNG.

    Upgraded to dev brach, but then the install from package manager fails with the following errors. Did I do something incorrectly, or is there just a conflict at this time with some of the packages?

    Thanks

    Matt

    
    >>> Installing pfSense-pkg-pfBlockerNG-devel... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking integrity... done (1 conflicting)
      - php56-5.6.34 [pfSense] conflicts with php72-7.2.7 [installed] on /usr/local/bin/php
    Checking integrity... done (0 conflicting)
    The following 63 package(s) will be affected (of 0 checked):
    
    Installed packages to be REMOVED:
    	pfSense-2.4.4.a.20180717.0730
    	php72-simplepie-1.5.1_1
    	php72-7.2.7
    	php72-pecl-rrd-2.0.1_1
    	pfSense-Status_Monitoring-php72-1.7.6
    	php72-gettext-7.2.7
    	php72-sqlite3-7.2.7
    	php72-pdo_sqlite-7.2.7
    	php72-pdo-7.2.7
    	php72-readline-7.2.7
    	php72-curl-7.2.7
    	php72-pear-XML_RPC2-1.1.3_1
    	php72-pear-HTTP_Request2-2.3.0,1
    	php72-pear-Net_URL2-2.2.1
    	php72-pear-1.10.5_1
    	php72-xml-7.2.7
    	php72-zlib-7.2.7
    	php72-pear-Net_Socket-1.0.14
    	php72-pear-Net_SMTP-1.8.0
    	php72-pear-Mail-1.4.1,1
    	php72-pear-Cache_Lite-1.7.16,1
    	php72-pear-Crypt_CHAP-1.5.0
    	php72-hash-7.2.7
    	php72-pecl-mcrypt-1.0.1
    	php72-pear-Net_IPv6-1.3.0.b2_2
    	php72-pear-Net_Growl-2.7.0
    	php72-pear-Auth_RADIUS-1.1.0_3
    	php72-pecl-radius-1.4.0.b1
    	php72-pfSense-module-0.62_5
    	php72-tokenizer-7.2.7
    	php72-mbstring-7.2.7
    	php72-dom-7.2.7
    	php72-xmlreader-7.2.7
    	php72-openssl-7.2.7
    	php72-openssl_x509_crl-1.2
    	php72-bcmath-7.2.7
    	php72-session-7.2.7
    	php72-opcache-7.2.7
    	php72-xmlwriter-7.2.7
    	php72-simplexml-7.2.7
    	php72-ctype-7.2.7
    	php72-posix-7.2.7
    	php72-filter-7.2.7
    	php72-sockets-7.2.7
    	php72-ldap-7.2.7
    	php72-pecl-zmq-1.1.3_2
    	php72-sysvshm-7.2.7
    	php72-sysvsem-7.2.7
    	php72-sysvmsg-7.2.7
    	php72-shmop-7.2.7
    	php72-pcntl-7.2.7
    	php72-json-7.2.7
    	php72-bz2-7.2.7
    
    New packages to be INSTALLED:
    	pfSense-pkg-pfBlockerNG-devel: 2.2.1 [pfSense]
    	lighttpd: 1.4.48_1 [pfSense]
    	lua52: 5.2.4 [pfSense]
    	whois: 5.2.17 [pfSense]
    	GeoIP: 1.6.11 [pfSense]
    	iprange: 1.0.3 [pfSense]
    	grepcidr: 2.0 [pfSense]
    	php56: 5.6.34 [pfSense]
    	pecl-intl: 3.0.0_11 [pfSense]
    	icu: 60.2_1,1 [pfSense]
    
    Number of packages to be removed: 53
    Number of packages to be installed: 10
    
    The process will require 38 MiB more space.
    pkg-static: Cannot delete vital package: pfSense!
    pkg-static: If you are sure you want to remove pfSense, 
    pkg-static: unset the 'vital' flag with: pkg set -v 0 pfSense
    Failed
    
    

  • Moderator



  • Do you know what version of pfsense would be compatible?


  • Moderator

    @matt1544 said in failed install pfBlockerNG-devel: 2.2.1 on pfSense-2.4.4.a.20180717.0730:

    Do you know what version of pfsense would be compatible?

    2.4.3 or less