HTTPS not working correctly with Squid Proxy



  • Hi!
    When I setup pfSense/Squid to log all entries on port 443, it does not work correctly.
    It keeps blocking some HTTPS sites in some computers and other sites like https://trello.com just won't connect.
    Can anyone tell me what am I doing wrong?
    Thank you already.

    My config:
    2 lan rules, rerouting everything from port 80/443 to port 3128*;

    Squid Proxy Server enabled, port 3128, transparent http proxy (lan interface), SSL Filtering enabled (Lan), SSLMITM mode Splice All, port 3129, CA: BRT CA, Do not verify remote certificate.

    Squid Guard Proxy Filter enabled, Blacklist enabled, URL: http://www.shallalist.de/Downloads/shallalist.tar.gz

    Squid Proxy Reports (Lightsquid): Port 7445, Lightsquid Web SSL enabled, IP Resolve Method DNS.

    How I created my CA: System > Cert. Manager > CAs > Add.
    Name: Brt CA, Self signed.

    .* I tried to reroute port 443 to port 3129 but it didn't work.

    BTW, can I log HTTPS requests in other ports that I don't know the number?



  • Hi
    I had the same problem
    But I put the list IP of this site in Bypass and the problem was resolved

    Go to Firewall Aliases>ADD+
    Name: trello
    Type : Network(s)
    23.45.96.0/20
    104.66.78.18/20

    Save

    And Go to Services > Squid Proxy server
    in Bypass Proxy for These Destination IPs type : trello

    Save and restart squid service