Pfsense not picking up WAN ip, computer not connecting to internet.



  • Hello all,
    This is the first time i try putting pfsense into my home network and since i have a pretty decent rig i decided to run it in VMware instead of hassling with another PC.
    I have 3 NIC's: Mobo integrated Realtek(not being used), 2x Intel Pro/1000 Gt Desktop Adapters.
    I followed both guides located at:
    http://doc.pfsense.org/index.php/Installing_pfSense_in_vmware_under_windows &
    http://files.pfsense.org/mirror//tutorials/vmware_install/vmware.html
    But my WAN just won't pickup an ip address from my modem(its cable internet so no pppoe needed).
    I bridged VMnet0 with my Lan and VMnet2 with my WAN nic's.
    I unchecked everything except "VMware bridge protocol" in the WAN nic settings.
    I tried using the live CD in my VMware but no go. Then tried the 1.2.2 VM appliance and still no go.
    Also tried switching adapters in the pfsense settings just in case i got them mixed-up.

    Here are some screenshots of my VMnet Configs:










  • I had problems with me WAN DHCP giving different ip networks/gateways to the physical machine and the virtual machine, this
    lead to an odd network problem that might be similar to your problem. (I could ping but not use TCP connection).
    The solution was to go two static IP on the same network with the same gateway one for the real machine and one for virtual machine.



  • I had basicly same problem installing in the vmware server I found that my network links in the virtual machine even though showing bridged from what I understand now it was the main bridged adapeter rather then vmnet2/vmnet3 I recomend you go back to http://doc.pfsense.org/index.php/Installing_pfSense_in_vmware_under_windows and look at Summery of Virtual Machine settings picture there then go back and make sure you have actually selected the vmnet2 in your actual virtual machine.  After I linked the adapter correctly there my pppoe connection worked.


Log in to reply