Problema configurando pfSense con 2 WAN



  • Hola a todos.

    Tengo la version de Version 2.4.3-RELEASE-p1, he realizado una configuracion para tener redundancia con mi 2 proveedores de Internet, defino WAN 1 como tier1 y WAN 2 como Tier 2, el Trigger esta como Member Down, tambien tengo configurado el monitoreo con IP's de 2 DNS externos, esta creada la regla para que todo lo que venga de mi LAN lo envie por el Gateway que se llama LoadBalancing que es el nombre que le definir, sin embargo cuando desconecto la interface WAN 1 no se switchea a la WAN 2 para salir a Internet, hay alguna configuracion adicional que deberia hacer o tiene algun problema esta version para correr Loadbalancing.

    de antemano gracias por su colaboracion
    Slds



  • Hola

    Habilita esto en

    System Advanced Miscellaneous
    

    Load Balancing
    Use sticky connections

    Default gateway switching
    Enable default gateway switching



  • Hola Gerson

    te comento que hice la configuracion que me recomendastes pero igual al tener abajo WAN 1 no se me switchea el trafico a salir por Wan 2, quiero mencionar que si yo configuro manualmente a sacar el trafico por Wan 2, este funciona, lo menciono para dejar claro que ambas redes WAN estan permitidas con salida a Internet, pero no me esta funcionado el Switcheo automatico de 2 WAN.

    gracias por tu colaboracion



  • al descoenctar la wan 1 el gateway pasa a estado down?



  • Si


  • Rebel Alliance

    Si "Muestras" (capturas de pantalla) cómo tienes configurado tu pfSense, será mas fácil que los compañeros puedan "ver" dónde está el error/problema.



  • Hola

    les comento que reinstale pfSense y volvi hacer la configuracion, creando el Gateway Group donde defini Tier 1, Tier 2 con Member Down, luego agrege 2 IP's de Servidores en Internet para el Monitoreo de los 2 Gateway que tengo, despues active Use sticky connections, Enable default gateway switching tal y como me lo dijo Gerson y por ultimo en la regla de salida a internet defini como Gateway el Group que cree y ya me funciona el Load Balancing, doy por cerrado el caso y gracias por la ayuda.


  • Rebel Alliance

    Disculpa, pero en un "entorno" "Multi-WAN" con "Failover"

    No necesitas habilitar "Use sticky connections"

    Tampoco es necesario habilitar "default gateway switching" salvo caso que utilices el "DNS Resolver" (en modo Resolver) y que los usuarios de la LAN utilicen al pfSense como DNS.

    https://www.netgate.com/docs/pfsense/routing/multi-wan.html

    https://www.netgate.com/docs/pfsense/dns/unbound-dns-resolver.html

    edit:
    agregar "default gateway switching"



  • @ptt perfecto lo tomare en cuenta y voy a desabilitar y ver que funcione la redundancia.



  • @jorge-murga un gusto ayudarte

    saludos