Is there a way to use Remote Access on WAN DHCP



  • hi i posted couple spots as i want Remote Access VPN and use a VPN Service
    i find out from NordVPN i can not use PPPOE On the WAN Interface has to be DHCP

    but OpenVPN -Remote Access does not work for WAN Interface DHCP it starts to connect and then hangs at the IP address i use Dynamic DNS also.
    it only works in PPPOE.. then it will allow a connection

    so i very frustrated and confused why PPPOE works but DHCP Doesnt.. and my modems firewall is off..

    but if i have to use WAN interface in DHCP ... how do you get Remote Access OpenVPN to work... with using the Dynamic DNS on pfsense



  • or how do you PFsense experts use a VPN Service and a Remote Access VPN Service(Local Network Access ) at the same time


  • Netgate

    None of what you are saying is making any sense.

    You can use OpenVPN on any WAN type - DHCP or PPPoE.

    If you want a Remote Access Server and a VPN client then set up a Remote Access Server and set up a VPN client. Doing one does not mean you can't do the other. If you want to run multiple servers you just have to set different listening ports.



  • i have youtube videos
    https://youtu.be/x1sbKyaLPWw

    soo
    when i have
    WAN Interface (DHCP) ------>NordVPN(DHCP) works VPN Remote Access network doesnt

    WAN Interface (PPPOE) ----> NordVPN(DHCP) does not work VPN Remote Acccess to network works...

    NordVPN replied "it seems that once you are connected with the PPPoE, the VPN cannot get the correct gateway to access the Internet and therefore fails. The only proper way to resolve this issue is to use the DHCP on the WAN interface."

    my video doesnt show the OpenVPN Client i use to access my network i only did the nordVPN

    when i connect to openvpn client side to access my network it just hangs in DHCP

    Sat Jul 28 12:24:42 2018 OpenVPN 2.4.4 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Sep 26 2017
    Sat Jul 28 12:24:42 2018 Windows version 6.2 (Windows 8 or greater) 64bit
    Sat Jul 28 12:24:42 2018 library versions: OpenSSL 1.0.2l 25 May 2017, LZO 2.10
    Sat Jul 28 12:24:46 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]174.94.28.150:1196
    Sat Jul 28 12:24:46 2018 UDP link local (bound): [AF_INET][undef]:1194
    Sat Jul 28 12:24:46 2018 UDP link remote: [AF_INET]x.x.x.x:1196



  • also spent over a week with NordVpn tech support and there higher up tech department cant resolve this issue


  • Netgate

    @comet424 said in Is there a way to use Remote Access on WAN DHCP:

    Sat Jul 28 12:24:46 2018 UDP link local (bound): [AF_INET][undef]:1194
    Sat Jul 28 12:24:46 2018 UDP link remote: [AF_INET]x.x.x.x:1196

    Why are you binding the local source port to 1194?



  • not sure where this binding is but i dont set a 1194
    the only 1194 is the NordVPN
    the settings for OpenVPN Remote Access is only set for 1196 as i wanted a space between 1194 (NordVPN) and Remote Access so i set it to 1196

    but if i set WAN Interface to PPPOE I get it to connect
    Sat Jul 28 13:45:32 2018 OpenVPN 2.4.4 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Sep 26 2017
    Sat Jul 28 13:45:32 2018 Windows version 6.2 (Windows 8 or greater) 64bit
    Sat Jul 28 13:45:32 2018 library versions: OpenSSL 1.0.2l 25 May 2017, LZO 2.10
    Sat Jul 28 13:45:33 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]174.94.29.182:1196
    Sat Jul 28 13:45:33 2018 UDP link local (bound): [AF_INET][undef]:1194
    Sat Jul 28 13:45:33 2018 UDP link remote: [AF_INET]x.x.x.x:1196
    Sat Jul 28 13:45:33 2018 [mikeshouseserver] Peer Connection Initiated with [AF_INET]x.x.x.x:1196
    Sat Jul 28 13:45:35 2018 open_tun
    Sat Jul 28 13:45:35 2018 TAP-WIN32 device [Ethernet 2] opened: \.\Global{742C798F-D787-40B2-94B3-A2A97530B345}.tap
    Sat Jul 28 13:45:35 2018 Set TAP-Windows TUN subnet mode network/local/netmask = 192.168.100.0/192.168.100.2/255.255.255.0 [SUCCEEDED]
    Sat Jul 28 13:45:35 2018 Notified TAP-Windows driver to set a DHCP IP/netmask of 192.168.100.2/255.255.255.0 on interface {742C798F-D787-40B2-94B3-A2A97530B345} [DHCP-serv: 192.168.100.254, lease-time: 31536000]
    Sat Jul 28 13:45:35 2018 Successful ARP Flush on interface [9] {742C798F-D787-40B2-94B3-A2A97530B345}
    Sat Jul 28 13:45:35 2018 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
    Sat Jul 28 13:45:40 2018 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
    Sat Jul 28 13:45:40 2018 Initialization Sequence Completed

    As you can see WAN (PPPOE) works but WAN(DHCP) Above hangs.. and i dont know where the 1194 that seems to be automatic i cant find this binding you speak of in the settings



  • and i followed the CrossTalk video steps to do this and there is no 1194 in it that i set
    https://www.youtube.com/watch?v=Q6YbCQEiC3c