pfBlockerNG-devel: 2.2.5_9 install error



  • Hi I tried installing the latest development version and I got stock at this line

    [5/115] Deinstalling pear-Crypt_CHAP-1.5.0...
    

    What I did was remove the "keep settings" in pfBlockerNG, then de-installed pfBlockerNG 2.4.3_8 using package manager, rebooted and installed the latest development version, maybe I gave up to soon, but after I got stuck on the line above for about 20 minutes, I gave up, did a reboot using the console and tried to enter the webinterface of pfSense, it gave me:

    PHP ERROR: Type: 64, File: /etc/inc/config.inc, Line: 51, Message: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear')
    
    

    So I had to reinstalled pfSense, then restored my config. Tried it again and then got stuck on one line earlier, so at

    4/115] Deleting files for pear-Net_SMTP-1.8.0........... done
    

    Below the complete output from the Package Manager Installation (I hope it helps):

    >> Installing pfSense-pkg-pfBlockerNG-devel... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 10 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-pfBlockerNG-devel: 2.2.5_9 [pfSense]
    	lighttpd: 1.4.49 [pfSense]
    	lua52: 5.2.4 [pfSense]
    	php72: 7.2.8 [pfSense]
    	libargon2: 20171227 [pfSense]
    	whois: 5.2.17 [pfSense]
    	iprange: 1.0.3 [pfSense]
    	grepcidr: 2.0 [pfSense]
    	php72-intl: 7.2.8 [pfSense]
    	icu: 62.1_1,1 [pfSense]
    
    Number of packages to be installed: 10
    
    The process will require 77 MiB more space.
    15 MiB to be downloaded.
    [1/10] Fetching pfSense-pkg-pfBlockerNG-devel-2.2.5_9.txz: .......... done
    [2/10] Fetching lighttpd-1.4.49.txz: .......... done
    [3/10] Fetching lua52-5.2.4.txz: .......... done
    [4/10] Fetching php72-7.2.8.txz: .......... done
    [5/10] Fetching libargon2-20171227.txz: ........ done
    [6/10] Fetching whois-5.2.17.txz: ........ done
    [7/10] Fetching iprange-1.0.3.txz: ... done
    [8/10] Fetching grepcidr-2.0.txz: ... done
    [9/10] Fetching php72-intl-7.2.8.txz: .......... done
    [10/10] Fetching icu-62.1_1,1.txz: .......... done
    Checking integrity... done (1 conflicting)
      - php72-7.2.8 [pfSense] conflicts with php56-5.6.34 [installed] on /usr/local/bin/php
    Checking integrity... done (0 conflicting)
    Conflicts with the existing packages have been found.
    One more solver iteration is needed to resolve them.
    The following 115 package(s) will be affected (of 0 checked):
    
    Installed packages to be REMOVED:
    	pear-XML_RPC2-1.1.3
    	pear-Mail-1.4.1,1
    	pear-HTTP_Request2-2.3.0,1
    	pear-Net_SMTP-1.8.0
    	pear-Crypt_CHAP-1.5.0
    	pear-Net_URL2-2.2.1
    	pear-Cache_Lite-1.7.16,1
    	pear-Net_Socket-1.0.14
    	pear-Net_IPv6-1.3.0.b2_2
    	pear-Net_Growl-2.7.0
    	pear-Auth_RADIUS-1.1.0
    	pear-1.10.5_1
    	php56-xmlreader-5.6.34
    	php56-xml-5.6.34
    	php56-pdo_sqlite-5.6.34
    	pfSense-Status_Monitoring-1.7.6
    	php56-dom-5.6.34
    	php56-xmlwriter-5.6.34
    	php56-simplexml-5.6.34
    	php-suhosin-0.9.38_3
    	php56-session-5.6.34
    	php56-gettext-5.6.34
    	php56-mcrypt-5.6.34
    	php56-hash-5.6.34
    	php56-zlib-5.6.34
    	php56-curl-5.6.34
    	php56-pfSense-module-0.61
    	pecl-zmq-1.1.3_2
    	php56-sqlite3-5.6.34
    	php56-pdo-5.6.34
    	pecl-radius-1.4.0.b1
    	php56-readline-5.6.34
    	pecl-rrd1-1.1.3
    	php56-tokenizer-5.6.34
    	php56-sysvshm-5.6.34
    	php56-sysvsem-5.6.34
    	php56-sysvmsg-5.6.34
    	php56-sockets-5.6.34
    	php56-shmop-5.6.34
    	php56-posix-5.6.34
    	php56-pcntl-5.6.34
    	php56-openssl-5.6.34
    	php56-opcache-5.6.34
    	php56-mbstring-5.6.34
    	php56-ldap-5.6.34
    	php56-json-5.6.34
    	php56-filter-5.6.34
    	php56-ctype-5.6.34
    	php56-bz2-5.6.34
    	php56-bcmath-5.6.34
    	php56-5.6.34
    
    New packages to be INSTALLED:
    	libargon2: 20171227 [pfSense]
    	php72: 7.2.8 [pfSense]
    	php72-xml: 7.2.8 [pfSense]
    	php72-zlib: 7.2.8 [pfSense]
    	php72-pear: 1.10.5_1 [pfSense]
    	oniguruma: 6.8.1 [pfSense]
    	php72-pear-Net_URL2: 2.2.1 [pfSense]
    	php72-pear-Net_Socket: 1.0.14 [pfSense]
    	lua52: 5.2.4 [pfSense]
    	php72-curl: 7.2.8 [pfSense]
    	php72-tokenizer: 7.2.8 [pfSense]
    	php72-mbstring: 7.2.8 [pfSense]
    	php72-dom: 7.2.8 [pfSense]
    	php72-pecl-rrd: 2.0.1_1 [pfSense]
    	php72-openssl: 7.2.8 [pfSense]
    	php72-hash: 7.2.8 [pfSense]
    	php72-bcmath: 7.2.8 [pfSense]
    	php72-pecl-mcrypt: 1.0.1 [pfSense]
    	php72-pecl-radius: 1.4.0.b1 [pfSense]
    	php72-pear-HTTP_Request2: 2.3.0,1 [pfSense]
    	php72-pear-Cache_Lite: 1.7.16,1 [pfSense]
    	php72-pear-Net_SMTP: 1.8.0 [pfSense]
    	php72-pdo: 7.2.8 [pfSense]
    	icu: 62.1_1,1 [pfSense]
    	lighttpd: 1.4.49 [pfSense]
    	php72-simplepie: 1.5.1_1 [pfSense]
    	php72-session: 7.2.8 [pfSense]
    	php72-opcache: 7.2.8 [pfSense]
    	php72-xmlwriter: 7.2.8 [pfSense]
    	php72-xmlreader: 7.2.8 [pfSense]
    	php72-simplexml: 7.2.8 [pfSense]
    	php72-ctype: 7.2.8 [pfSense]
    	php72-posix: 7.2.8 [pfSense]
    	pfSense-Status_Monitoring-php72: 1.7.6 [pfSense]
    	php72-filter: 7.2.8 [pfSense]
    	php72-openssl_x509_crl: 1.2 [pfSense]
    	php72-pear-Crypt_CHAP: 1.5.0 [pfSense]
    	openvpn-auth-script: 1.0.0.3 [pfSense]
    	php72-sockets: 7.2.8 [pfSense]
    	php72-ldap: 7.2.8 [pfSense]
    	php72-pecl-zmq: 1.1.3_2 [pfSense]
    	php72-pear-XML_RPC2: 1.1.3_1 [pfSense]
    	php72-pear-Net_IPv6: 1.3.0.b2_2 [pfSense]
    	php72-pear-Net_Growl: 2.7.0 [pfSense]
    	php72-pear-Auth_RADIUS: 1.1.0_3 [pfSense]
    	php72-pear-Mail: 1.4.1,1 [pfSense]
    	php72-sysvshm: 7.2.8 [pfSense]
    	php72-sysvsem: 7.2.8 [pfSense]
    	php72-sysvmsg: 7.2.8 [pfSense]
    	php72-shmop: 7.2.8 [pfSense]
    	php72-readline: 7.2.8 [pfSense]
    	php72-pcntl: 7.2.8 [pfSense]
    	php72-json: 7.2.8 [pfSense]
    	php72-gettext: 7.2.8 [pfSense]
    	php72-pfSense-module: 0.62_6 [pfSense]
    	php72-sqlite3: 7.2.8 [pfSense]
    	php72-pdo_sqlite: 7.2.8 [pfSense]
    	php72-bz2: 7.2.8 [pfSense]
    	whois: 5.2.17 [pfSense]
    	iprange: 1.0.3 [pfSense]
    	grepcidr: 2.0 [pfSense]
    	php72-intl: 7.2.8 [pfSense]
    	pfSense-pkg-pfBlockerNG-devel: 2.2.5_9 [pfSense]
    
    Installed packages to be UPGRADED:
    	pfSense: 2.4.3_1 -> 2.4.4.a.20180803.1452 [pfSense]
    
    Number of packages to be removed: 51
    Number of packages to be installed: 63
    Number of packages to be upgraded: 1
    
    The process will require 57 MiB more space.
    3 MiB to be downloaded.
    [1/54] Fetching php72-xml-7.2.8.txz: ... done
    [2/54] Fetching php72-zlib-7.2.8.txz: ... done
    [3/54] Fetching php72-pear-1.10.5_1.txz: .......... done
    [4/54] Fetching oniguruma-6.8.1.txz: .......... done
    [5/54] Fetching php72-pear-Net_URL2-2.2.1.txz: ... done
    [6/54] Fetching php72-pear-Net_Socket-1.0.14.txz: . done
    [7/54] Fetching php72-curl-7.2.8.txz: .... done
    [8/54] Fetching php72-tokenizer-7.2.8.txz: .. done
    [9/54] Fetching php72-mbstring-7.2.8.txz: .......... done
    [10/54] Fetching php72-dom-7.2.8.txz: ....... done
    [11/54] Fetching php72-pecl-rrd-2.0.1_1.txz: .. done
    [12/54] Fetching php72-openssl-7.2.8.txz: ....... done
    [13/54] Fetching php72-hash-7.2.8.txz: .......... done
    [14/54] Fetching php72-bcmath-7.2.8.txz: ... done
    [15/54] Fetching php72-pecl-mcrypt-1.0.1.txz: .. done
    [16/54] Fetching php72-pecl-radius-1.4.0.b1.txz: ... done
    [17/54] Fetching php72-pear-HTTP_Request2-2.3.0,1.txz: .......... done
    [18/54] Fetching php72-pear-Cache_Lite-1.7.16,1.txz: .... done
    [19/54] Fetching php72-pear-Net_SMTP-1.8.0.txz: .. done
    [20/54] Fetching php72-pdo-7.2.8.txz: ...... done
    [21/54] Fetching php72-simplepie-1.5.1_1.txz: ......... done
    [22/54] Fetching php72-session-7.2.8.txz: ..... done
    [23/54] Fetching php72-opcache-7.2.8.txz: .......... done
    [24/54] Fetching php72-xmlwriter-7.2.8.txz: .. done
    [25/54] Fetching php72-xmlreader-7.2.8.txz: .. done
    [26/54] Fetching php72-simplexml-7.2.8.txz: ... done
    [27/54] Fetching php72-ctype-7.2.8.txz: . done
    [28/54] Fetching php72-posix-7.2.8.txz: .. done
    [29/54] Fetching pfSense-Status_Monitoring-php72-1.7.6.txz: ... done
    [30/54] Fetching php72-filter-7.2.8.txz: ... done
    [31/54] Fetching php72-openssl_x509_crl-1.2.txz: .. done
    [32/54] Fetching php72-pear-Crypt_CHAP-1.5.0.txz: . done
    [33/54] Fetching openvpn-auth-script-1.0.0.3.txz: . done
    [34/54] Fetching php72-sockets-7.2.8.txz: ..... done
    [35/54] Fetching php72-ldap-7.2.8.txz: ... done
    [36/54] Fetching php72-pecl-zmq-1.1.3_2.txz: .... done
    [37/54] Fetching php72-pear-XML_RPC2-1.1.3_1.txz: ........ done
    [38/54] Fetching php72-pear-Net_IPv6-1.3.0.b2_2.txz: .. done
    [39/54] Fetching php72-pear-Net_Growl-2.7.0.txz: .......... done
    [40/54] Fetching php72-pear-Auth_RADIUS-1.1.0_3.txz: .. done
    [41/54] Fetching php72-pear-Mail-1.4.1,1.txz: ... done
    [42/54] Fetching php72-sysvshm-7.2.8.txz: . done
    [43/54] Fetching php72-sysvsem-7.2.8.txz: . done
    [44/54] Fetching php72-sysvmsg-7.2.8.txz: . done
    [45/54] Fetching php72-shmop-7.2.8.txz: . done
    [46/54] Fetching php72-readline-7.2.8.txz: .. done
    [47/54] Fetching php72-pcntl-7.2.8.txz: .. done
    [48/54] Fetching php72-json-7.2.8.txz: ... done
    [49/54] Fetching php72-gettext-7.2.8.txz: . done
    [50/54] Fetching php72-pfSense-module-0.62_6.txz: ...... done
    [51/54] Fetching php72-sqlite3-7.2.8.txz: ... done
    [52/54] Fetching php72-pdo_sqlite-7.2.8.txz: .. done
    [53/54] Fetching php72-bz2-7.2.8.txz: .. done
    [54/54] Fetching pfSense-2.4.4.a.20180803.1452.txz: . done
    [1/115] Deinstalling pear-XML_RPC2-1.1.3...
    uninstall ok: channel://pear.php.net/XML_RPC2-1.1.3
    [1/115] Deleting files for pear-XML_RPC2-1.1.3: 
    pear-XML_RPC2-1.1.3: missing file /usr/local/share/doc/pear/XML_RPC2/docs/Makefile
    [1/115] Deleting files for pear-XML_RPC2-1.1.3...
    pear-XML_RPC2-1.1.3: missing file /usr/local/share/doc/pear/XML_RPC2/docs/tutorials/XML_RPC2.lyx
    [1/115] Deleting files for pear-XML_RPC2-1.1.3............. done
    [2/115] Deinstalling pear-Mail-1.4.1,1...
    uninstall ok: channel://pear.php.net/Mail-1.4.1
    [2/115] Deleting files for pear-Mail-1.4.1,1: 
    pear-Mail-1.4.1,1: missing file /usr/local/share/doc/pear/Mail/LICENSE
    [2/115] Deleting files for pear-Mail-1.4.1,1............. done
    [3/115] Deinstalling pear-HTTP_Request2-2.3.0,1...
    uninstall ok: channel://pear.php.net/HTTP_Request2-2.3.0
    [3/115] Deleting files for pear-HTTP_Request2-2.3.0,1: 
    pear-HTTP_Request2-2.3.0,1: missing file /usr/local/share/doc/pear/HTTP_Request2/LICENSE
    [3/115] Deleting files for pear-HTTP_Request2-2.3.0,1...
    pear-HTTP_Request2-2.3.0,1: missing file /usr/local/share/doc/pear/HTTP_Request2/examples/upload-rapidshare.php
    [3/115] Deleting files for pear-HTTP_Request2-2.3.0,1............. done
    [4/115] Deinstalling pear-Net_SMTP-1.8.0...
    uninstall ok: channel://pear.php.net/Net_SMTP-1.8.0
    [4/115] Deleting files for pear-Net_SMTP-1.8.0: 
    pear-Net_SMTP-1.8.0: missing file /usr/local/share/doc/pear/Net_SMTP/LICENSE
    [4/115] Deleting files for pear-Net_SMTP-1.8.0...
    pear-Net_SMTP-1.8.0: missing file /usr/local/share/doc/pear/Net_SMTP/docs/guide.txt
    [4/115] Deleting files for pear-Net_SMTP-1.8.0...
    pear-Net_SMTP-1.8.0: missing file /usr/local/share/doc/pear/Net_SMTP/examples/basic.php
    [4/115] Deleting files for pear-Net_SMTP-1.8.0........... done
    [5/115] Deinstalling pear-Crypt_CHAP-1.5.0...
    
    
    


  • Well the latest pfBlockerNG development version from the pfSense development branch is based on php 7, as is the latest development version of pfSense. Trying to install this on a current stable build, which ist still based on php 5, will obviously mess up your pfSense installation. So don't do it unless you want to look pretty stupid.

    If you want to use pfBlockerNG-devel on a stable pfSense build use the version from the stable branch.



  • Thanks for pointing that one out to me. I missed it, because I read this one, https://www.reddit.com/r/PFSENSE/comments/8lnugz/pfblockerng_devel_version_released/ ,which suggests it was only downloadable from the unstable branch, as I did not expect a development release in the stable branch... 😎