Wireless card but no Wireless Configuration stanza in webgui



  • Hi,
    just searched the forum up and down, but I could not find anything. I'm using pfSense 1.2.2 on an alix board. Just added a Intel 2100 wireless card, whích is detected, and which is also detected in the webgui. But when I click on Interfaces I don't see the stanza "Wireless Configuration".

    alix:/boot#  ifconfig ipw0
    ipw0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    ether 00:04:23:61:38:2e
    inet6 fe80::204:23ff:fe61:382e%ipw0 prefixlen 64 scopeid 0x3
    inet 192.168.10.1 netmask 0xffffff00 broadcast 192.168.10.255
    media: IEEE 802.11 Wireless Ethernet autoselect
    status: no carrier
    ssid "" channel 3 (2422 Mhz 11b)
    authmode OPEN privacy OFF bmiss 7 scanvalid 60
    alix:/boot#  ifconfig ipw0 list caps
    ipw0=1818300 <ibss,pmgt,shpreamble,monitor,wpa1,wpa2>Looks enough wireless to me?

    But I can't configure it…

    Thanks for any pointers
    Klaus</ibss,pmgt,shpreamble,monitor,wpa1,wpa2></up,broadcast,running,promisc,simplex,multicast>



  • I SUSPECT that ipw needs to be in the list of wireless interfaces in /etc/inc/globals.inc

    Look for the line with "wireless_regex" => … and add ipw to the list

    I don't know if that change will be sufficient.



  • I believe this card does not support AP mode. I remember someone going through a bunch of work getting their 2200 working only to find out it wouldn't work as an access point. If you don't need ap mode, then carry on.



  • @wallabybob:

    I SUSPECT that ipw needs to be in the list of wireless interfaces in /etc/inc/globals.inc

    Look for the line with "wireless_regex" => … and add ipw to the list

    I don't know if that change will be sufficient.

    Well, I thought, that's it! because it sounds so reasonable, and easy, too ;-) But alas, it's obviously not sufficient. I added it, and I tried all, inclusive reboot, but still the config options don't show up on the interface sections. Thanks, I still think that's part of the solution

    I believe this card does not support AP mode. I remember someone going through a bunch of work getting their 2200 working only to find out it wouldn't work as an access point. If you don't need ap mode, then carry on.

    true, this card does not work as an ap (ifconfig list caps don't show this capability, either. And in the end I'd like to have a card that's capable. But right now it would be sufficient to get it going in ad-hoc or infrastructure, just to explore the possibilities… Mind you, I got this card for 1.50 EUR from ebay, so some testing is not so much of a problem :-)

    Thanks all

    Klaus



  • Have you looked at the FreeBSD man page for ipw? (see http://www.freebsd.org/cgi/man.cgi?query=ipw&apropos=0&sektion=0&manpath=FreeBSD+7.1-RELEASE&format=html )

    Perhaps (speculation follows) the device firmware needs to be loaded and started before it will generate the necessary responses to allow the wireless configuration stanza to be displayed. It still may not be sufficient to load the firmware but its almost certainly necessary to get a working interface.

    The Intel 2200 sticky note in this forum probably shows what has to be done (but replacing iwi by iwp ). However the 2100 driver is apparently already in the kernel so you wouldn't need the loader.conf line to load the device driver.



  • Hi,

    yes, I followed the man page, and I can configure the card on the command line.  I changed the loader.conf, copied the corresponding ipw kernel modules to the proper place and added all parameters from iwi replaced with ipw, and I even created the structure in /usr/share do point to the directory containing the README because of the license parameter. The card is detected fine now (and has to, as otherwise I guess I wouldn't be able to configure it via cli)

    Well, probably not so important then, as I guess I'll have to get an atheros based card if I want to have an ap. But before I just wanted to test everything…

    Thanks,
    Klaus


Locked