LAGG broken in 2.4.3-RELEASE-p1



  • When I create a LAGG, it shows up under ifconfig. But as soon as I assign a static IP to the LAGG, the LAGG disappears from ifconfig and no longer communicates with the switch.

    I also tried doing a VLAN on the LAGG. Same thing happens. It shows up at first, but then disappears as soon as I assign a static IP address to it.

    I tried this with both LACP and LOADBALACE LAGGs.



  • Turns out that it was worse than I first thought. Adding a LAGG with an IP address destroys all routing. You then have to reset PF to factory defaults. :(


  • Netgate

    Yeah except lots of people are using laggs without such problems.

    You are probably going to have to give more details.



  • Well, it may have been the NIC. I'm not completely sure. I don't think a NIC issue would cause the LAGG to disappear once an IP addresses is assigned. This was on a clean install on an Intel NUC with a certified FreeBSD compatible NIC.

    Oh well. I had to switch back to my PF VM.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy