Official Realtek Driver v1.95 Binary



  • Realtek released v1.95 of their FreeBSD driver on August 3, 2018:
    Driver Page Link

    I downloaded and compiled the driver in a FreeBSD 11.1 VM and successfully booted the module on my Zotac CI323 Nano running 2.4.3-RELEASE-p1. I know that at least the updated version of this machine, the CI327 Nano, uses the same driver. I don't know what has changed in v1.94 relative to v1.95, because I was unable to locate any change log or release notes from Realtek. So update at your own risk. I'll be sure to post back if I run into any troubles myself.

    Link to compiled v1.95 driver:
    if_re_ko_v195.zip

    If you're already running the v1.94 driver, all you need to do is extract this ZIP file, change ownership and permissions on the if_re.ko file within:
    chown root:wheel if_re.ko
    chmod 0555 if_re.ko
    Then copy it to /boot/kernel/
    cp if_re.ko /boot/kernel/
    Then reboot.

    It wouldn't be a bad idea to back up the if_re.ko you have before replacing it:
    cp /boot/kernel/if_re.ko /boot/kernel/if_re_ko.bak

    If you weren't already using Realtek's official driver, you also need to add the line:
    if_re_load="YES"
    to /boot/loader.conf.local.

    To verify that the driver is loaded, execute:
    kldstat | grep if

    The output should show if_re.

    EDIT: I updated the if_re_ko_v195.zip file today (8/7/18). The original was uploaded on 8/6/18 and I had tested it and verified that it was working for me. However, I had built it with my existing pfSense 2.4 source, and I thought it would be prudent to grab the latest. So I cloned branch RELENG_2_4 of FreeBSD-src (https://github.com/pfsense/FreeBSD-src.git) and re-built against that. The resulting binary was different (as checked using shasums), so I'm updating the file here. I am currently running with this binary and know that it works.


  • Netgate Administrator

    I assume that's 64bit?

    Probably quite a few 32bit users running re NICs still.

    Steve



  • @stephenw10 I knew I'd forget some critical detail . . . yes that's 64-bit. If I get a chance I'll grab a 32-bit 11.1 10.3 VM and compile under it against the 2.3.5 sources as well.



  • @stephenw10 I've made what I consider to be a valiant effort to compile a 32-bit version of this module, but with no luck so far. I started by cloning the RELENG_2_3 label of FreeBSD-src (https://github.com/pfsense/FreeBSD-src.git) and can build the 64-bit module. But when I try to build 32-bit, I receive a bunch of errors:
    0_1533658757403_clang_errors.png

    I've also tried to build using gcc (FreeBSD Ports version 6.4.0) instead of clang and receive the error:
    0_1533658676419_gcc_error.png

    Now, I was attempting to cross-compile from a FreeBSD 11.1 64-bit environment, which I thought should be possible, but maybe not. I'll still try to grab a 10.3 32-bit VM soon and see whether it's happier then . . .



  • @stephenw10 Got it; a 32-bit 10.3 VM worked. So the following was built against the RELENG_2_3 branch of https://github.com/pfsense/FreeBSD-src.git:

    32-bit Realtek v1.95 Driver: if_re__ko_v195_32bit.zip

    Please note that I do not have a 32-bit pfSense 2.3.5 system with which to test, so this module has not been tested by me.



  • @thenarc Working fine in my CI323, thanks for compiling this for us. 😀



  • @wogman Glad to hear it! And no problem. I'll try to get one out ASAP once 2.4.4 is released also. In theory I believe I could do it in advance now by compiling against the official FreeBSD 11.2 kernel source, but I figure it's best to wait and compile against the pfSense 2.4.4 kernel source once it's finalized.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy