Captive portal problem



  • Morning.

    I had a pfsense with squid, squidward, clamav, cicap, snort and captive portal working perfectly.

    Today, i changed the LAN and WAN adresses and then , i have this problems :

    • Captive portal doesnt appear, (but i get access to the ssid and get internet). I tried to access to the portal manually and it worked fine, that is confusing me

    • Had ICAP protocol error while tried to access some pages

    what the trouble? it worked fine until now

    thanks your time



  • Hi,

    The WAN IP changes for millions of us every day or every week. That didn't "break" the portal.

    But : changing the LAN could imply far more then "change some data on the Interface page and done". You didn't say what you did - neither if this implies settings on packages like "squid, squidward, clamav, cicap, snort" (I'm using none of these) so ... can't tell from here what you forget to change.

    Btw ; but you did find one more reason non to run the captive portal on LAN - thanks for that.