pfBlockerNG errors when GoeIP enabled



  • I have only been using pfSense a couple weeks now and I installed pfBlockerNG to use for ad blocking. That has been working fine.
    Then I saw you could also use it to block other countries using GeoIP. I watched a quick video on setting it up / using it. Highlight what you want then choose the list action and then save.
    after doing this I started seeing a red notification bell and these are an example of the errors I'm getting

    Filter Reload
    	•	There were error(s) loading the rules: /tmp/rules.debug:30: cannot define table pfB_Top_v4: Cannot allocate memory - The line in question reads [30]: table <pfB_Top_v4> persist file "/var/db/aliastables/pfB_Top_v4.txt"
    @ 2018-08-08 19:23:48
    	•	There were error(s) loading the rules: /tmp/rules.debug:30: cannot define table pfB_Top_v4: Cannot allocate memory - The line in question reads [30]: table <pfB_Top_v4> persist file "/var/db/aliastables/pfB_Top_v4.txt"
    @ 2018-08-08 19:25:01
    	•	There were error(s) loading the rules: /tmp/rules.debug:30: cannot define table pfB_Top_v4: Cannot allocate memory - The line in question reads [30]: table <pfB_Top_v4> persist file "/var/db/aliastables/pfB_Top_v4.txt"
    @ 2018-08-08 19:26:32
    	•	There were error(s) loading the rules: /tmp/rules.debug:30: cannot define table pfB_Top_v4: Cannot allocate memory - The line in question reads [30]: table <pfB_Top_v4> persist file "/var/db/aliastables/pfB_Top_v4.txt"
    @ 2018-08-08 19:30:09
    	•	There were error(s) loading the rules: /tmp/rules.debug:30: cannot define table pfB_Top_v4: Cannot allocate memory - The line in question reads [30]: table <pfB_Top_v4> persist file "/var/db/aliastables/pfB_Top_v4.txt"
    @ 2018-08-08 19:30:38
    	•	There were error(s) loading the rules: /tmp/rules.debug:32: cannot load "/var/db/aliastables/pfB_Top_v6.txt": No such file or directory - The line in question reads [32]: table <pfB_Top_v6> persist file "/var/db/aliastables/pfB_Top_v6.txt"
    @ 2018-08-08 19:31:58
    	•	
    
    

  • Moderator

    In pfSense > System > Advanced > Firewall & NAT > "Firewall Maximum Table Entries"

    The package should default that to "2000000" entries.

    Follow that with a Filter Reload



  • That setting was default to 400000. I'll change it and try again.
    Thanks
    Edit: Tried and works without errors now.
    Thanks


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy