Pfsense and myqnapcloud cloundlink

  • Hi. i have installed my pfsense router yesterday, everything works fine exept the Firewall blocking my Qnap dns service myqnapcloud.

    I know that i have to open the ports, but because i am new to pfsense, i don't know exactly how.

    When i go to Firewall - Rules - LAN and add a new Rule, i don't know what settings i have to put in.

  • LAYER 8 Global Moderator

    you wouldn't put anything on the lan, you would need to create a port forward for the port that service uses. Or you would have to use UPnP for the application running on your nas to auto open the port.

    To be honest I wouldn't suggest opening up that to the public internet unless you could lock down the source port to specific IPs you or your friends would be coming from.

    If you really want to open it, and you know the ports it uses - then
    Firewall / NAT / Port Forward

    And forward the port to your nas IP. Again not very secure to open up such services to the public internet. Can you not just vpn into your network if you want to access your nas remotely?

  • @johnpoz VPN would be my preferred final solution, but i'm really new in this firewall, network stuff and i don't really get it, how to set up a VPN.

  • LAYER 8 Global Moderator

    Run thru the openvpn vpn wizard..

    The book is now available for everyone.

    So that is going to have all the info you would need to setup remote access.

    And the handouts avail as well - there is 2 parter on remote vpn access. I you have specific questions - start a thread in the vpn section with your specifics.
    Youtube Video

  • Hi. Thanks for the Link. I tried it 6 months ago, but gave up. Now i have a new NAS and i gave it a new try.

    I followed the steps and i managed to configure the openVPN Server. Createt a Certificate and an User with Certificate. I export the Settings and import it to the openVPN client on Android, but no connection

    do i Miss something? i followed the instructions step by step.

    Something that does not go in my head. How does the client, that is not in the same Network, know where to find my Server? In the tutorial i never had to specify an Address, only an IPv4 Tunnel Network Address.

  • LAYER 8 Global Moderator

    When you export the config..


  • LAYER 8 Global Moderator

    You understand if pfsense is behind a NAT you have to forward the port to it for this to ever work.. And if behind a nat when you export it would put your rfc1918 address in the client - and then NO It would never connect..

    Pick custom and put in your IP or some fqdn ddns that resolves to public IP where pfsense is, etc..

  • @johnpoz said in Pfsense and myqnapcloud cloundlink:


    Thank you.

    Host Name Resolution was already Set to "Interface IP Address"
    My pfsense is not behind a NAT Firewall

    by "custom" you mean the setting "other"?

    Sorry that i ask these stupid questions. Im not really a pro in Network stuff. The only reason i try to make VPN work is because pfsense is blocking the myqnapcloud dns service.

    Edit: OK, wow i just found out i had to check the box with the DNS Default Domain and the DNS Server.
    I watched this tutorial
    and right at the point where he explains what DNS Default Domain is, he just skipps this step!!!!

  • LAYER 8 Global Moderator

    so what does the client log show? Is it trying to connect to your pfsense public IP? What does the openvpn log on pfsense show?

Log in to reply