Ark Server Cluster NAT issue



  • I have recently moved over to Pfsense and am having an issue with my Ark Survival Evolved cluster. Both internal and external connectivity is fine and everyone can connect fine.

    However when I try to transfer between servers ingame, the other servers are not visible. However external users can transfer between them without issue.

    This is the NATs i have setup for the server currently - (No NAT Reflection)

    0_1534686987219_ce0ecc2a-9009-4bb8-8f8a-f550f297e5f4-image.png

    My guess is that after i have connected to the server from my LAN which gets NATed, it then cannot see the other servers as it doesn't seem them as external I guess?

    Hoping someone can help me out with what i may need to change to resolve this!





  • I did look at doing that, but the game servers rely purely on IP and not hostnames so i didn't think that would be an option. Happy to be corrected if that's not the case though.



  • Well then use internal IPs to connect your internal clients. NAT reflection is pretty crappy at best and only usefull if nothing else works.



  • @grimson I just disabled "Pure NAT" and let it fall back to the default of no NAT Reflection and everything is still working as before. I'd have assumed it would need that, but it works so that's the main thing.

    However the transfer between servers once connected is still an issue.



  • Any other suggestions?

    If it helps, this is the exact problem i'm having - https://survivetheark.com/index.php?/forums/topic/99424-server-cluster-transfer-in-lan-not-working/

    As far as i know, the root of the issue is - You can connect to a server locally on LAN and play fine, but it only searches over WAN when looking for servers to transfer too ingame. This is my problem because my other two servers are also on my LAN.

    Is there some network wizardry that could be done to resolve this?

    Only option i can think of currently is using a VPN, which i don't really want to do.



  • I haven't had the chance to use these as I host from a Windows store server and they have blocked a lot of these settings. But Google did point me to these 2 options when I went searching ages ago.

    [SessionSettings]
    SessionName=New ARK Server
    MultiHome=localip
    Port=7777
    QueryPort=27015
    

    The above can be added to gamesettings.ini (If it still works I can't test) or else you can try adding multihome to the launcher cmd in steam.

    start ShooterGameServer.exe TheIsland?SessionName=MyServer?ServerPassword=MyPassword?MaxPlayers=20?MultiHome=127.0.0.1?Port=27015?QueryPort=27016
    

    Obviously you need to add your cluser-id to the launcher in there as well.



  • Thanks for the suggestion, I have got my MultiHome set to my local IP already and it has been working fine since the cluster release. But since i moved from my old ISP router to Pfsense i now have this issue.

    Old Setup - I could join any of the 3 servers and transfer between them ingame.

    Pfsense - I can join any of the 3 servers, but cannot transfer between servers ingame. (it doesn't even show them in the list)

    I wonder if i need to have some sort of outbound nat to force my client to go external, but i'm really not sure!



  • Resolved the issue by enabling the tick box "Enable automatic outbound NAT for Reflection" in System > Advanced > Firewall & NAT. It even says in the description that this needs to be enabled for NAT Refection to work properly, just wish it had prompted me to enable it when i set Pure NAT mode in the rules i setup.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy