OpenVPN Wizard failure



  • I'm trying to create an OpenVPN server using the built-in wizard, but each time I get to the last step, it errors out saying I need to select a new CA certificate, and returns me to that step in the process.

    A little about my setup. I'm using a Supermicro SYS-5019A-FTN4, which requires me to run 2.4.4-DEVELOPMENT for C3000 SoC interface support.

    I've tried creating the CA and Server certs in the Wizard as well as separately via System --> Cert Manager. From what I can tell, the CA and server cert's look fine. If I create the server manually, it does complete. However, when I try and use the "Client Export" package, nothing shows up under "OpenVPN Clients". Based on the paragraph in blue, it seems like there is a "CA mismatch".

    Anyways, I'm a first time pfsense user, so it's entirely possible I'm forgetting something. I appreciate your help and thank you in advance.


  • Rebel Alliance Developer Netgate

    Before you can export, you have to create some users with certificates that also use the same CA that the VPN uses. The wizard won't create the users for you, those have to be done manually afterward.

    There was a problem with the wizard I found and fixed yesterday, so a snapshot from late yesterday or early today should be better.



  • Thanks jimp. Grabbing the latest build solved the problem. Thanks for your help!


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy