openvpn wizard from 2.4.3 x creating wrong firewall rules



  • Recently I installed a new device with the latest pfsense version, when I configured OpenVPN I noticed some "small" bugs that create wrong firewall rules that won't allow to use OpenVPN in the easy way we were used to be with old pfsense releases.

    1. create your own Firewall-rule-WAN, be focused on the port and protocol you will use, if you used wizard it will probably create a wrong one.

    2. In my case I need openVPN clients traffic go through the tunnel so their IP will be pfsense's WAN IP. In my case this was not working at all.
      force all clients-generated IPv4 traffic through the tunnel was activated but Firewall-rule-Open VPN had a wrong rule created by the wizard.
      What the wizard created was Protocol IPv4 UDP on Port 35000
      but what fixed the bug was to disable that rule and the create a new one
      Protocol IPv4 * and Port *


  • Rebel Alliance Developer Netgate

    That bug has been fixed for quite some time. If you are still hitting that problem, you are not on the most recent version. Upgrade to 2.4.3-p1 ASAP.

    Note that installing from ISO or Memstick will get you 2.4.3, not 2.4.3-p1, you must update online after installation to reach the latest patch release.



  • @jimp I don't know how, but I got the same results even with -p1
    0_1534975581300_c3150dac-c7bd-4925-821e-8b5ce90e73cf-image.png


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy