The Forest Server



  • Having another issue connecting locally to my The Forest game server behind pfsense.

    I have setup a port forward which works fine and i can connect externally when over a VPN. However internally i cannot see the server in the list.

    What do i need to do to fix this? Pfsense has been great but not being able to connect to various local game servers is a real issue. I would like to connect over the internet and not locally.



  • Resolved the issue by enabling the tick box "Enable automatic outbound NAT for Reflection" in System > Advanced > Firewall & NAT. It even says in the description that this needs to be enabled for NAT Refection to work properly, just wish it had prompted me to enable it when i set Pure NAT mode in the rules i setup.



  • If your game server is on your LAN, what difference does it make whether to you connect via its LAN IP or public address? It's the same server. NAT Reflection (aka Hairpinning) is a less-than-optimal solution. A better solution is to add a host override to your pfSense DNS so that your server's public hostname gets resolved to its LAN IP instead of its public IP. Or do you not use a FQDN and only use your public IP address to connect?



  • Thanks for the reply, I had wanted to go down that route as well and have done with my webserver. But unfortunately all the game servers i run rely on IP only which is a pain! After a lot of looking around, i couldn't find any other workaround for that.



  • ??? All Internet services rely on IP only per se (with exceptions). DNS is a convenience for us humans. Anyway if NAT reflection works for you then good.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy