Writing the snapshot image so it boots



  • I'm trying to write out the image on a mac to a USB flash drive using this command:

    cat pfSense-CE-memstick-2.4.4-DEVELOPMENT-amd64-latest.img | sudo dd of=/dev/disk2 bs=1m

    It writes fine and I can mount the resulting disk. However I'm unable to boot from it. Using the same procedure on a release version instead of the development version gives me a bootable drive. Is there a different procedure to use for the development version? I've also tried other images that are bootable and they boot and work fine (ie linux images).


  • Netgate

    Just use www.etcher.io

    (The command would be sudo dd if=pfSense-CE-memstick-2.4.4-DEVELOPMENT-amd64-latest.img of=/dev/rdisk2 bs=64k)

    The 2.4.4 dev images are hybrid (ISO and memstick image). You could possibly be running into some sort of incompatibility there.



  • Thanks for the reply, I did try it that way as well and same result:

    sudo dd if=pfSense-CE-memstick-2.4.4-DEVELOPMENT-amd64-latest.img of=/dev/rdisk4 bs=64k

    I can see in Disk Utility the disk is an ISO9660 drive. This is the memory stick. Still can't boot it though. I also tried switching the machine from Dual to Legacy in the BIOS but no luck.


  • Netgate

    I won't be able to be of much help but for someone else you probably want to detail what you are trying to boot it on in as much detail as possible.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy