PFSense не видит свитч



  • Приветствую!
    Ситуация вкратце:
    В сети есть примерно такая структура:
    alt text
    PFSense установлен на древний комп, имеет 2 физических интерфейса, один из которых настроен на доступ в интернет.
    На 2м интерфейсе настроено 2 вилана и локалка. Этот интерфейс соединён через обычный неуправляемый 8портовый Dlink с 8м портом T2500G-10TS. Конфиг T2500G-10TS:

    !T2500G-10TS
    #
    vlan 10,20
    #
    vlan 10
    name "10"
    #
    vlan 20
    name "20"
    #
    #
    #
    #
    #
    location "Some City"
    #
    mac address-table aging-time 300
    #
    logging buffer 6
    no logging file flash
    #
    #
    no service password-encryption
    #
    system-time ntp UTC+04:00 95.213.132.254 213.28.138.38 12
    #
    #
    user name admin privilege admin secret 5 ****************************
    #
    #
    mac-vlan mac-address 50:c7:bf:7f:69:15 vlan 1 description "tplink"
    #
    #
    #
    #
    #
    #
    port-channel load-balance src-dst-mac
    #
    #
    #
    ip ssh server
    #
    ip dhcp relay
    ip dhcp relay information option
    ip dhcp relay vlan 1 helper-address 192.168.0.122
    #
    #
    #
    interface gigabitEthernet 1/0/1
      switchport mode general
      switchport general allowed vlan 10 untagged
      switchport pvid 10
      port isolation gi-forward-list 1/0/7-8
      ip igmp snooping
    #
    interface gigabitEthernet 1/0/2
    #
    interface gigabitEthernet 1/0/3
      switchport mode general
      switchport general allowed vlan 20 untagged
      switchport pvid 20
    #
    interface gigabitEthernet 1/0/4
    #
    interface gigabitEthernet 1/0/5
    #
    interface gigabitEthernet 1/0/6
    #
    interface gigabitEthernet 1/0/7
      switchport mode general
      ip igmp snooping
    #
    interface gigabitEthernet 1/0/8
      switchport mode trunk
      switchport trunk allowed vlan 10,20
      ip igmp snooping
      description "Trunk to vlans"
    #
    interface gigabitEthernet 1/0/9
      speed 1000
      duplex full
    #
    interface gigabitEthernet 1/0/10
      speed 1000
      duplex full
    #
    ip igmp snooping vlan-config 1
    ip igmp snooping vlan-config 1 rport interface gigabitEthernet 1/0/8
    interface vlan 1
    ip address 192.168.0.123 255.255.255.0 192.168.0.122
    #
    interface vlan 1
    no ipv6 enable
    #
    end
    
    

    Получается такая ситуация:
    Клиенты на 1 и 2 порту T2500G-10TS спокойно сидят в интернет, каждый в своём влане.
    С компа 192.168.0.124 я спокойно пингую, захожу на веб интерфейс, телнечусь и эсэсашусь как T2500G-10TS, так и PFSense. При этом PFSense не пингует и вообще в упор не видит T2500G-10TS и наоборот. Но зато они оба прекрасно видят комп. В настройках фаервола нет никаких ограничивающих правил для T2500G-10TS и его айпишника. Tcpdump'ом не вижу никакого трафика на адрес T2500G-10TS, ни с PFSense, ни с компа.

    Подскажите где искать причину ?



  • Доброго дня
    а что будет , если убрать из схемы неуправляемый свитч ?
    Т е 8 порт коммутатора соединить напрямую с PFSENSE ?
    и комп включить в любой порт VLAN 1 T2500

    и еще вопрос - пробовали посмотреть пакеты ARP , например , на интерфейсе LAN PFSENSE ?

    P S Почитал документацию , разработчики PFsense не рекомендуют использовать VLAN 1 на транковом порту
    если Вам надо , чтобы PFsense и свитч видели друг друга , поменяйте адрес свича на адрес из любой 10.0 или 20.0



  • Добрый.

    VLAN 1 по умолч. исп-ся у больш-ва произ-лей как дефолтный для управления.
    Крайне рекомендуется VLAN 1 не использовать , оставив его только для управления оборудованием (?)


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy