Squid NTLM Config Proxy Work with IP but no work with DNS (IE and Chrome)



  • Hi.

    I config Squid with auth AD NTLM. Work fine for IP Proxy.

    Example: 192.168.1.7 Port 8080

    But when config Proxy with DNS:
    Example: proxy.mydomain.com Port 8080 no Work.

    Show popup Auth, But no work.

    What could it be?

    Thanks.



  • @j-sejo1 The problem was?

    IE and Chrome when use Proxy for DNS. the way auth is kerberos.

    When use Proxy for IP the way auth is Ntlm.

    Firefox by default use NTLM.

    Solved: In Propierties, option avanced, IE Disable: Integrations Autentication WIndows.

    The best practices: is: on Squid enable auth:

    Kerberos
    NTLM
    Basic