Block IGMP multicast on bridge member



  • Hi all,

    I have the following setup:

    • igb0: WAN
    • igb1: DMZ
    • bridge0: LAN (10.0.0.1/24)
      • igb2: access point (linksys e3200 in bridge mode)
      • igb3: Apple TV

    net.link.bridge.pfil_member and net.link.bridge.pfil_bridge are swapped.

    My ISP provides IPTV via IGMP multicast. I plan to use the Apple TV to us the IPTV service, that's why I configured an IGMP proxy from WAN to LAN. Additionally, firewall rules on WAN and LAN interfaces with IP options enabled have to be created.
    Now, whenever the IPTV application is started on Apple TV, the access point wifi port starts having a high latency (up to multiple seconds), eventually total loss of connection. It looks like the AP is not able to handle IGMP multicast traffic, and, as it is running in bridge mode, there is also no way to disable/block this on the AP itself.

    Of course I could separate igb2 and igb3 into different subnets and eventually solve the issue, but that way, airplay from wireless would not work (I guess?). On the other hand, blocking multicast traffic towards interface igb2, or somehow force it to go via igb3 only, is not really possible, is it?

    Any suggestion on how to "fix" this?


Log in to reply