PPPoE not reconnecting after boot or Line drop in Hyper-V VM



  • Hi

    I am currently running pfsense 2.4.3-Release-p1 as a Server2012r2 Hyper-V virtual machine, which in general seems to work very well.I am using a Draytek Vigor 130 modem.

    However, a problem that I have never been able to resolve is that every time the VM or host machine reboots, pfsense reconnection to the PPPoE WAN fails. It intially seems to connect (for about 20 seconds or so) but then goes offline. On the console I see the message "altq: packet for pppoe0 does not have pkthdr". I have tried both having the pfsense VM shutdown when the server does and having it enter a saved state but still get the same issue.

    As a workaround I just disconnect and reconnect the interface (either under the status menu or via the interfaces menu) and it is fine again. This workaround isnt great because if the host does a windows update when I am away from home, there is no way to re-establish internet connectivity until I physically get back.

    Is there is known issue with this for VMs, is there a tweak I can do, or failing that, is it possible to produce a bash script that will detect interface failure and automatically disconnect and reconnect?

    Any thoughts would be welcome.

    Thanks


Log in to reply