Can't play COD:BO4 Blackout, port 3074 won't forward



  • So, I got into the beta and I have connection issue with the game because apparently port 3074 needs to be open.

    I put my PS4 on UPNP so it should work fine. But when I checked the port with port checker tool, it's closed. Here's my UPNP setting.

    0_1537104216120_ebd1140b-3968-4261-a556-590fa6a61ad3-image.png

    192.168.0.104 is my PS4 internal IP.

    So I went to System Logs > Firewall and it's showing me this

    0_1537104495609_51731d5f-6da5-49e6-b361-f1110da8703b-image.png

    The red part is my external IP and Diagnostics > States is not showing anything related to 3074.

    Any idea why? Any help will be appreciated.



  • I haven't tried UPNP and I don't use a PS4 but I do play the COD series, mainly BO3 on PC using Steam. Below are several edited screenshots of my settings that should work for you even though you are trying to set up BO4 and are using a different platform to play. I think some of the ports you need to open for the game may be different for PS4 but you should be able to find them with a net search. The settings in the screenshots below give me an in-game open-NAT.

    0_1537157204402_udp-aliases.png
    0_1537157241632_tcp-aliases.png
    0_1537157268063_nat-port_forward.png
    0_1537157290995_outbound-nat.png
    0_1537157320552_firewall_rules-wan.png
    0_1537157337789_firewall_rules-lan.png

    I use a VPN so I named a gateway in the LAN rules to send my game port traffic out the WAN. Depending on your configuration, you may not have to worry about them yourself. Also in my LAN rules you can see I am using subnet aliases for the destination. Depending on you configuration you could probably just use the subnet IP that your PS4 is on or just the PS4 IP for the destination.

    Hope this helps and if not hopefully someone more familiar with UPNP can help.



  • Well that's odd, I'm not seeing the screenshots I posted in my first reply. If I mouse over the empty area between my paragraphs my mouse cursor changes to a hand and I can click to open the screenshots.

    Sorry.. I'll have to look into this.



  • Adding Outbound NAT for port 3074 fixed it.

    0_1537156797867_f4152bf5-5efe-4041-9558-8f0e5216cac0-image.png



  • Glad to hear you got it working.

    I found my problem as well. Turns out the forum doesn't seem to like gif's for an image format so I changed them to png's and now I can see them. Even though you fixed your issue, I went ahead and fixed the screenshots so that they might help someone else.


Log in to reply