Lost access to webGui after changing from HTTPS to HTTP



  • Hello,
    By mistake, i changed the port of webconfigurator from https to http. And now, i cannot access it using my admin password, while i can access console with username admin and my password.
    Any help please?
    Thanks.



  • Hi,

    First thing to try : do not use the FQDN (like http(s)://pfsense.yourlan.tld ) anymore, use the IP address, and if needed, force it a little bit : http://192.168.1.1:80/



  • Thank you.
    The login webpage is displayed, but no access when i enter username/password which was not changed.



  • Try to login, but this time use a browser that you never use to access pfSense.
    There will be no caching issues.
    Same thing : use another PC / device.

    If you still experience a no-go, activate the console and use Option 3.



  • Thank you for your help.
    I just reinstalled pfSense before reading your comment.
    But i'll manage to try this in test environment.
    Thank you again.



  • I think there’s an option in the advanced settings regarding an HTTPS feature called HSTS (HTTP Strict Transport Security) that will tell the browser to always use HTTPS when going to that host. I believe HSTS is enabled by default when HTTPS is enabled.

    You may need to find where in your browser you can go to clear the HSTS setting for your pfSense hostname and/or IP address in order to access it without HTTPS. Or as suggested, you can always use a different browser.


Log in to reply