2.4.4RC errors with pfblocker



  • Getting errors on latest RC's running pfblocker..

    Unresolvable source alias 'pfB_Asia_v4' for rule 'pfB_Asia_v4 auto rule' @ 2018-09-19 19:08:03
    Unresolvable source alias 'pfB_Europe_v4' for rule 'pfB_Europe_v4 auto rule' @ 2018-09-19 19:08:04
    Unresolvable source alias 'pfB_SAmerica_v4' for rule 'pfB_SAmerica_v4 auto rule' @ 2018-09-19 19:08:05
    Unresolvable source alias 'pfB_Top_v4' for rule 'pfB_Top_v4 auto rule' @ 2018-09-19 19:08:06
    Unresolvable source alias 'pfB_Asia_v4' for rule 'pfB_Asia_v4 auto rule' @ 2018-09-19 19:08:07
    Unresolvable source alias 'pfB_Europe_v4' for rule 'pfB_Europe_v4 auto rule' @ 2018-09-19 19:08:08
    Unresolvable source alias 'pfB_SAmerica_v4' for rule 'pfB_SAmerica_v4 auto rule' @ 2018-09-19 19:08:09
    Unresolvable source alias 'pfB_Top_v4' for rule 'pfB_Top_v4 auto rule' @ 2018-09-19 19:08:10
    Unresolvable source alias 'pfB_Asia_v4' for rule 'pfB_Asia_v4 auto rule' @ 2018-09-19 19:08:11
    Unresolvable source alias 'pfB_Europe_v4' for rule 'pfB_Europe_v4 auto rule' @ 2018-09-19 19:08:12
    Unresolvable source alias 'pfB_SAmerica_v4' for rule 'pfB_SAmerica_v4 auto rule' @ 2018-09-19 19:08:13
    Unresolvable source alias 'pfB_Top_v4' for rule 'pfB_Top_v4 auto rule' @ 2018-09-19 19:08:14
    

    PHP Errors:
    [19-Sep-2018 18:00:01 America/Vancouver] PHP Warning: Illegal string offset 'vtype' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4082
    [19-Sep-2018 18:00:01 America/Vancouver] PHP Warning: Illegal string offset 'key' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4088
    [19-Sep-2018 18:00:01 America/Vancouver] PHP Warning: Illegal string offset 'vtype' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4084
    [19-Sep-2018 18:00:01 America/Vancouver] PHP Warning: Illegal string offset 'key' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4088
    [19-Sep-2018 18:00:01 America/Vancouver] PHP Warning: Illegal string offset 'alias' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4670
    [19-Sep-2018 18:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689
    [19-Sep-2018 18:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689
    [19-Sep-2018 18:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689
    [19-Sep-2018 19:00:01 America/Vancouver] PHP Warning: Illegal string offset 'vtype' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4082
    [19-Sep-2018 19:00:01 America/Vancouver] PHP Warning: Illegal string offset 'key' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4088
    [19-Sep-2018 19:00:01 America/Vancouver] PHP Warning: Illegal string offset 'vtype' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4084
    [19-Sep-2018 19:00:01 America/Vancouver] PHP Warning: Illegal string offset 'key' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4088
    [19-Sep-2018 19:00:01 America/Vancouver] PHP Warning: Illegal string offset 'alias' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4670
    [19-Sep-2018 19:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689
    [19-Sep-2018 19:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689
    [19-Sep-2018 19:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689
    [19-Sep-2018 20:00:01 America/Vancouver] PHP Warning: Illegal string offset 'vtype' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4082
    [19-Sep-2018 20:00:01 America/Vancouver] PHP Warning: Illegal string offset 'key' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4088
    [19-Sep-2018 20:00:01 America/Vancouver] PHP Warning: Illegal string offset 'vtype' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4084
    [19-Sep-2018 20:00:01 America/Vancouver] PHP Warning: Illegal string offset 'key' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4088
    [19-Sep-2018 20:00:01 America/Vancouver] PHP Warning: Illegal string offset 'alias' in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4670
    [19-Sep-2018 20:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689
    [19-Sep-2018 20:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689
    [19-Sep-2018 20:00:01 America/Vancouver] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 4689


  • Moderator

    I believe that you are on an old release of pfBlockerNG. These PHPv7 errors were previously addressed.
    Are you on pfBlockerNG or pfBlockerNG-devel?



  • @bbcan177 said in 2.4.4RC errors with pfblocker:

    pfBlockerNG

    pfBlockerNG 2.1.4_9


  • Moderator

    @chpalmer said in 2.4.4RC errors with pfblocker:

    pfBlockerNG 2.1.4_9

    Ok I see that these weren't fix in pfBlockerNG, but have been addressed in pfBlockerNG-devel.

    I will add some of these fixes to pfBlockerNG since there is an open PR, but I would suggest moving to pfBlockerNG-devel, if you can...

    Thanks!



  • @bbcan177

    Thanks!


  • Moderator

    All issues should be addressed in this PR:
    https://github.com/pfsense/FreeBSD-ports/pull/567

    Most of them were already in the PR, I just added one more commit tonight.

    Hopefully the devs merge this soon before more people move to 2.4.4 RC :)


Log in to reply