Wifi devices not connecting

  • I have a Pfsense box with opened DMZ behind my att uverse gateway.
    For some reason I can not add new wireless device to my network.

    Let me step back a bit.

    1. Pfsense box ----> 2. EA6900 Linksys wireless router Running in Bridge/AP mode.

    I have devices connected to it and are working great that are all setup with DHCP mapping in pfsense for each item on my network. I was trying to add a echo dot to my network but for some reason it would not add to the network and this dot was working fine a while back just diconnected it since i got a echo show but wanted to set it up in my sons room for use. I thought it was a sh**ty dot until I decided to add it to my hotspot in my truck and it works fine. Then i tried to use a EACHEN WiFi Wireless Inching Relay Monentary/Self-locking Switch Module DIY Smart Garage Door to use to connect for my garage door and it connected before setting up the pfsense box but now all of a sudden it wont connect to the wifi. Thats two devices that all of a sudden wont connect to my network. Am I missing something all of a sudden? I also checked the dhcp mapping to make sure these are not trying to pull the same addresses that they may have had in the past in which i would hope they would pull new DHCP addresses but still no no avail. any assistance or a kick in the right direction would surely help.

    Thanks in advance for the help!