IPsec performance Problem



  • Hallo zusammen,

    ich habe einen IPsec Tunnel (site to site) zwischen zwei Gegenstellen. Der Tunnel wird über ipv6 aufgebaut und das klappt auch soweit ganz gut.

    Pfsense A Anbindung: Deutsche Glasfaser 200 MBit up- und download.
    Pfsense B Anbindung: Vodafon 400 MBit down- und 25 MBit upload.

    Die Tunnel wird über ipv6 aufgebaut und tunnelt die ipv4 Subnetze der Gegenstellen.
    Soweit alles ganz gut, die Subnetze sehen sich und alles läuft.
    Nur leider ist die Performance sehr schlecht. Der Pfsense A bekommt gerade mal 2 - 2,5 MB/s auf die Leitung und anders herum nur 1 MB/s.
    Ich hatte auch schon mit MSS gespielt und bin jetzt bei 1200. Doch das kann lange nicht hin kommen.
    Die MTU der Gegenstellen ipv6 seitig beträgt 1452.

    Leider bin ich mit meinem Latein am ende wo noch was geändert werden muss.

    Gruß
    Chris


  • LAYER 8 Moderator

    @chris_6n said in IPsec performance Problem:

    Nur leider ist die Performance sehr schlecht. Der Pfsense A bekommt gerade mal 2 - 2,5 MB/s auf die Leitung und anders herum nur 1 MB/s.

    Hi!
    Das ist im ersten Moment mal ziemlich mies, aber du schreibst leider auch überhaupt nichts von der verwendeten Hardware?
    Aufbau läuft über v6 schreibst du. Haben beide Seiten native v6 Anbindung? Oder läuft eine ggf. über einen Tunnel?

    Gruß



  • Hi!

    Hardware ist auf beiden Seiten die gleiche:

    Intel(R) Celeron(R) CPU J3455 @ 1.50GHz
    Current: 1500 MHz, Max: 1501 MHz
    4 CPUs: 1 package(s) x 4 core(s)
    AES-NI CPU Crypto: Yes (active)

    Habe auch als ich den anderen Rechner noch hier hatte im Test auch um die ca. 300 MBit geschafft.

    Die Anbindungen sind beide native ipv6 Leitungen, also kein 6in4.
    Daher nur die Öffentliche ipv6 Adresse und ipv4 läuft über NAT beim Provider.

    Gruß


Log in to reply