IGMP Proxy funktioniert nicht mehr nach Upgrade auf 2.4.4



  • Hi,

    nach dem Update auf die Version 2.4.4 (von 2.4.3-p1) funktioniert der IGMP Proxy leider nicht mehr.

    Gibt folgenden Fehler:

    igmpproxy[65102]: There must be at least 1 Vif as upstream.
    

    Ich denke die neue Version des IGMP Proxys kommt mit dem PPPoE Interface nicht klar...
    Ich habe mit die vorherige Version des Proxys wieder von einer 2.4.3 ISO rüber kopiert. Jetzt kann ich wieder TV schauen... ;)

    Meine Konfig:
    ##------------------------------------------------------
    ## Enable Quickleave mode (Sends Leave instantly)
    ##------------------------------------------------------
    quickleave
    phyint pppoe0 upstream ratelimit 0 threshold 1
    altnet xxx.xxx.xxx.xxx/dd
    altnet xxx.xxx.xxx.xxx/dd
    altnet xxx.xxx.xxx.xxx/dd
    
    phyint re1.200 downstream ratelimit 0 threshold 1
    altnet yyy.yyy.yyy.yyy/dd
    
    phyint re0.400 disabled
    phyint re2 disabled
    phyint re0.50 disabled
    


  • Hallo @Beerman,

    falls du es noch nicht gesehen hast hier das Ticket dazu:
    https://redmine.pfsense.org/issues/8935

    Ist schon gemeldet :-)

    Bis dahin 0_1537960316542_igmpproxy.0 zum Download. Bitte ".0" als Dateiendung entfernen.
    /usr/local/sbin/igmpproxy
    Da muss die Datei hin. Ein Neustart und schwups geht es wieder.

    Viele Grüße



  • Hallo @bepo

    stimmt, das Ticket kommt von mir. :-P Das hatte ich vorgestern erstellt.

    Hier im Deutschen Teil des Forums hatte ich das eher als "Warnung" geschrieben, da hier ja viele IPTV (Entertain u. Co.) nutzen.

    Hatte, wie oben geschrieben, schon das "alte" binary von der 2.4.3 ISO kopiert. Damit funktioniert wieder alles!

    Aber vielen Dank, für Deine Antwort! :)



  • Das hatte ich fast vermutet :-) Danke dafür! Genau wegen EntertainTV ist es in Deutschland besonders verbreitet. Wollte die Datei hier trotzdem zum Download stellen, weil es gar nicht so leicht war, an die alte Datei zu kommen. Bei Netgate sind diese nicht mehr zum Download verfügbar.

    Viele Grüße!