2.1.4_10 crashed my 2.4.3 pfsense install (?)



  • I updated pfblockerng on my 2.4.3 installation to the latest stable version through the package manager, and after that my total pfsense install was f*ked up.
    Maybe to do with the new php not being compatible below pfsense 2.4.4?

    Reinstalling 2.4.3 and restoring my saved config resulted in the same issue after the packages were reinstalled.

    Only reinstalling with 2.4.4 and restorng the saved config gave me a working system again.

    anyone else this experience?


  • Moderator

    Its a strange issue, since 2.4.3 and the pfBlockerNG use the previous version of PHP, so there should be no changes there.
    Did you change your pfSense repo to the Development repo before installing pfBlockerNG?
    The only issue could be with pfBlockerNG-devel on 2.4.3, and having the pfSense-devel repos selected. So if you had this scenario, and tried to upgrade to pfBlockerNG-devel, it could install PHPv7 which would mess up pfSense 2.4.3 since that is on PHPv5.

    Hard to diagnose without some more details from the logs etc...



  • Me too.
    Update starts and after a while remains frozen to "[18/113] Extracting icu-62.1_1,1: " stage.
    Take a look of attached "0_1537867373943_pgblocker_log.txt pgblocker_log.txt" file.

    And taking a look on console, there are a lot of messages claiming missings dinamyc libraries like these:

    Warning: PHP Startup: Unable to load dynamic library 'xml.so' (tried: /usr/local/lib/php/20131226/xml.so (Cannot open "/usr/local/lib/php/20131226/xml.so"), /usr/local/lib/php/20131226/xml.so.so (Cannot open "/usr/local/lib/php/20131226/xml.so.so")) in Unknown on line 0
    Warning: PHP Startup: Unable to load dynamic library 'xmlwriter.so' (tried: /usr/local/lib/php/20131226/xmlwriter.so (Cannot open "/usr/local/lib/php/20131226/xmlwriter.so"), /usr/local/lib/php/20131226/xmlwriter.so.so (Cannot open "/usr/local/lib/php/20131226/xmlwriter.so.so")) in Unknown on line 0
    Warning: PHP Startup: Unable to load dynamic library 'zlib.so' (tried: /usr/local/lib/php/20131226/zlib.so (Cannot open "/usr/local/lib/php/20131226/zlib.so"), /usr/local/lib/php/20131226/zlib.so.so (Cannot open "/usr/local/lib/php/20131226/zlib.so.so")) in Unknown on line 0
    Warning: PHP Startup: Unable to load dynamic library 'zmq.so' (tried: /usr/local/lib/php/20131226/zmq.so (Cannot open "/usr/local/lib/php/20131226/zmq.so"), /usr/local/lib/php/20131226/zmq.so.so (Cannot open "/usr/local/lib/php/20131226/zmq.so.so")) in Unknown on line 0
    Warning: PHP Startup: Unable to load dynamic library 'pdo_sqlite.so' (tried: /usr/local/lib/php/20131226/pdo_sqlite.so (Cannot open "/usr/local/lib/php/20131226/pdo_sqlite.so"), /usr/local/lib/php/20131226/pdo_sqlite.so.so (Cannot open "/usr/local/lib/php/20131226/pdo_sqlite.so.so")) in Unknown on line 0
    Warning: PHP Startup: Unable to load dynamic library 'xmlreader.so' (tried: /usr/local/lib/php/20131226/xmlreader.so (Cannot open "/usr/local/lib/php/20131226/xmlreader.so"), /usr/local/lib/php/20131226/xmlreader.so.so (Cannot open "/usr/local/lib/php/20131226/xmlreader.so.so")) in Unknown on line 0

    And then pfsense is completely gone... no web interface is working and a PHP error appears:
    "Fatal error: Uncaught Error: Call to undefined function gettext() in /usr/local/www/index.php:34 Stack trace: #0 {main} thrown in /usr/local/www/index.php on line 34 "

    Do I have to reinstall everything to recover my pfsense box ?



  • @sisko212 said in 2.1.4_10 crashed my 2.4.3 pfsense install (?):

    /usr/local/lib/php/20131226

    and I guess the directory

    /usr/local/lib/php/20170718/
    

    exists now, which means PHP 7.2 is there now ...
    (@sisko212 : check this please).

    In-place downgrading isn't an option, so, @sisko212 : I guess (again !) it's time to do a clean install.

    edit : read also : https://forum.netgate.com/topic/135868/php-errors-after-upgrade-to-2-4-4/12





  • @grimson said in 2.1.4_10 crashed my 2.4.3 pfsense install (?):

    https://forum.netgate.com/topic/135890/pfsense-2-4-3-release-factory-image-php-5-6-removed-after-single-package-aws-wizard-upgrade/2

    I saw what you said over there.
    If some package is installed, or re installed and this package includes PHP, then that will be PHP7.2..
    This forces somewhat the passage to 2.4.4 - probably not everybody will be happy with that ....
    But, 2.4.4 is rock solid and works fine for me.



  • @gertjan
    This is strange, because, i did a fresh install just a week ago with 2.3.4 pfsense, and restored a previous configuration backup.



  • @gertjan for me this was the case. I saw the php72 package being installed during the update of the package, as well when doing a clean install of 243 with resoring previous configuration and packages.

    only solution for me was a clean install of 244 and then restore the previous config


  • Moderator


  • Rebel Alliance Developer Netgate



  • Solved after a fresh 2.4.4 install.
    Anyway 2.4.4 has open other issues (ex. c-icap and freeradius configurations had to be manually fixed, some issue on traffic shaper solved after rules recreations)
    To my personal opinion, could be a good idea lock packages upgrade to its pfsense version, and not to permit a package upgrade, from previous pfsense version, when a new one is available.