IE Zertrifikatsfehler



  • Hallo zusammen!

    Ich bekomme das mit den Zertifikaten nicht hin. IE meldet "Diese Website ist nicht sicher."

    Ich habe eine CA "PFSENSE CA" erstellt.
    Danach habe ich ein User Certifikate "pfSense WebIF Cert" erstellt. Aussteller "PFSENSE CA", CN = "pfsense.myhome.net". Dieses Zertifikat ist auch im pfSense webKonfigurator eingetragen, Protokoll steht auf HTTPS.

    Im Windows certmgr habe ich "PFSENSE+CA.crt" als Vertrauenswürdige Stammzertifizierungsstelle eingetragen und "pfSense+WebIF+Cert.p12" unter Eigene Zertifikate abgelegt.

    Leider klappt der Zugriff via IE immer noch nicht. Allerdings kommt jetzt die Meldung:
    Der DNS-Server hat möglicherweise Probleme.
    Fehlercode: INET_E_RESOURCE_NOT_FOUND

    Wo liegt der Fehler?

    Danke!
    Thomas



  • Wenn du über die IP darauf zugreifst, sollte es gehen.
    Über den Namen muss dann natürlich auch DNS funktionieren.
    Du kannst dies im Notfall über die "Hosts" Datei machen.

    Gruss
    Alitai



  • @alitai said in IE Zertrifikatsfehler:

    Wenn du über die IP darauf zugreifst, sollte es gehen.

    Allerdings kommt dann wieder eine Fehlermeldung, dass das Zertifikat ungültig ist, weil das auf den Namen "pfsense.myhome.net" ausgestellt ist.



  • Versuch mal in der Hosts Datei folgendes einzutragen:

    Ip abstand pfsense.myhome.net

    Also z.B.:
    192.168.0.2 pfsense.myhome.net



  • Moin,

    imho macht es mehr Sinn die Namensauflösung gleich mit der pfSense abzufrühstücken, je nachdem ob der DNS Forwarder oder der DNS Resolver Verwendung findet einfach unter Services dort unter Host Overrides eintragen. Vorteil: Es ist dann für alle Geräte im LAN erledigt, Nachteil: Funktioniert nicht wenn pfSense nicht der zuständige DNS fürs LAN ist 😏

    -teddy


  • Moderator

    @viragomann said in IE Zertrifikatsfehler:

    Allerdings kommt dann wieder eine Fehlermeldung, dass das Zertifikat ungültig ist, weil das auf den Namen "pfsense.myhome.net" ausgestellt ist.

    Was bei Zugriff via IP aber relativ egal sein sollte, das Login geht bei IP IMHO trotzdem, auch mit Fehler. Dass der kommt ist dann ja völlig normal. BTW sehe ich da eher noch andere Probleme wie:

    @esquire1968-0

    Danach habe ich ein User Certifikate "pfSense WebIF Cert" erstellt. Aussteller "PFSENSE CA", CN = "pfsense.myhome.net". Dieses Zertifikat ist auch im pfSense webKonfigurator eingetragen, Protokoll steht auf HTTPS.

    Du sagst User Zertifikat. Du brauchst aber ein Server Zertifikat - das muss ganz unten umgestellt werden von User auf Server. Macht sonst keinen Sinn, du willst ja einen Server Service anbieten, keine User Autorisierung.

    "pfSense+WebIF+Cert.p12" unter Eigene Zertifikate abgelegt.

    Das ist unnötig und sollte nicht notwendig sein, da das ausgelieferte Zertifikat gegen die CAs geprüft wird. Wenn die CA Kette stimmt, wird es automatisch gültig!

    Im Windows certmgr habe ich "PFSENSE+CA.crt" als Vertrauenswürdige Stammzertifizierungsstelle eingetragen

    Ein CRT? Sicher? IMHO kann Windows sinnvoll nur PKCS12 Zertifikate importieren, aber selbst wenn: hast du verifiziert, dass der Windows Certificate Store deine neue CA auch auflistet und sauber importiert hat? Bei meinen Tests war das manchmal nicht der Fall und erst ein zweiter Import hatte geklappt.

    Am Ende würde ich mit Chrome oder Chromium mal testen bevor ich den IE nehme, der dann wieder seine ganz eigenen Problemchen hat ;)

    Und das DNS würde ich auch irgendwo fix eintragen, damit man da nicht in der Hosts rumpfuschen muss.

    Gruß



  • Danke für Eure Hilfe!

    Mea culpa! Hatte ein User statt einem Server-Zertifikat angelegt ... darauf hätte ich auch kommen können.

    Jetzt klapp es mit dem mit der IP und dem Namen.