Error in AWS vpc vpn Wizard?


  • Rebel Alliance Global Moderator

    There was another thread user having an issue with wizard which I could not duplicate, so looking to see if maybe he was running some other wizard.. So on my sg4860 clicked on the AWS wizard and get this error

    PHP ERROR: Type: 64, File: /usr/local/www/wizards/vpc_vpn_wizard.inc, Line: 26, Message: require_once(): Failed opening required 'aws-sdk-php/aws-autoloader.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear:/usr/local/share/openssl_x509_crl/')

    Running
    2.4.4-RELEASE (amd64)
    built on Thu Sep 20 09:33:19 EDT 2018
    FreeBSD 11.2-RELEASE-p3

    Upgraded from 2.4.3p1
    Anyone else seeing this - have not checked redmine yet.



  • _seeing same issue here
    _upgraded yesterday
    _Netgate SG-4860
    _2.4.4-RELEASE (amd64)
    built on Thu Sep 20 09:33:19 EDT 2018
    FreeBSD 11.2-RELEASE-p3
    _PHP ERROR: Type: 64, File: /usr/local/www/wizards/vpc_vpn_wizard.inc, Line: 26, Message: require_once(): Failed opening required 'aws-sdk-php/aws-autoloader.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear:/usr/local/share/openssl_x509_crl/') @ 2018-09-26 11:54:10


  • Rebel Alliance Developer Netgate

    Looks like that was just a slight change in the path for the SDK files that snuck by. I pushed a fix, corrected pkg will show up momentarily.


  • Rebel Alliance Global Moderator

    Yeah new package available, 0.7_3

    Now when you click you get the gui like you should.. Thanks jimp