Pfsense 2.4.4 can't install / reinstall Squid Package 0.4.44_4



  • POST-INSTALL script of Squid Package 0.4.44_4 allways failed with following Log:

    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking integrity... done (0 conflicting)
    The following 1 package(s) will be affected (of 0 checked):

    Installed packages to be REINSTALLED:
    pfSense-pkg-squid-0.4.44_4 [pfSense]

    Number of packages to be reinstalled: 1
    [1/1] Reinstalling pfSense-pkg-squid-0.4.44_4...
    [1/1] Extracting pfSense-pkg-squid-0.4.44_4: .......... done
    Removing squid components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Deinstall commands... done.
    Saving updated package information...
    overwrite!
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...
    Fatal error: Uncaught Error: Cannot use string offset as an array in /usr/local/pkg/squid_reverse.inc:414
    Stack trace:
    #0 /usr/local/pkg/squid.inc(713): squid_reverse_upgrade_config()
    #1 /usr/local/pkg/squid.inc(472): squid_upgrade_config()
    #2 /etc/inc/pkg-utils.inc(768) : eval()'d code(1): squid_install_command()
    #3 /etc/inc/pkg-utils.inc(768): eval()
    #4 /etc/inc/pkg-utils.inc(854): eval_once('squid_install_c...')
    #5 /etc/rc.packages(74): install_package_xml('squid')
    #6 {main}
    thrown in /usr/local/pkg/squid_reverse.inc on line 414
    PHP ERROR: Type: 1, File: /usr/local/pkg/squid_reverse.inc, Line: 414, Message: Uncaught Error: Cannot use string offset as an array in /usr/local/pkg/squid_reverse.inc:414
    Stack trace:
    #0 /usr/local/pkg/squid.inc(713): squid_reverse_upgrade_config()
    #1 /usr/local/pkg/squid.inc(472): squid_upgrade_config()
    #2 /etc/inc/pkg-utils.inc(768) : eval()'d code(1): squid_install_command()
    #3 /etc/inc/pkg-utils.inc(768): eval()
    #4 /etc/inc/pkg-utils.inc(854): eval_once('squid_install_c...')
    #5 /etc/rc.packages(74): install_package_xml('squid')
    #6 {main}
    thrownpkg-static: POST-INSTALL script failed
    Message from pfSense-pkg-squid-0.4.44_4:

    Please visit Services - Squid Proxy Server menu to configure the package and enable the proxy.


  • Rebel Alliance Developer Netgate

    I can't seem to reproduce this here. Did you do anything special before attempting to install squid? Do you have any other packages installed?

    Does your configuration have <installedpackages> inside? Maybe you restored from a configuration that had all packages removed?

    Looking at the code, I can sort of see how what you're seeing might happen, so I can start working on a fix, but I'd like to know what condition your firewall was in to let it get to this point.


  • Rebel Alliance Developer Netgate

    Try squid 0.4.44_5 when you see it.



  • I fixed the problem with backup config, cut out the Squid-Reverse Proxy section and Restore the modified backup file. Then the Squid-Package installed without problem.

    Also does the new package 0.4.44_5.

    the problem was inside this section:
    <squidreverse>
    <config>
    <reverse_interface>wan</reverse_interface>
    <reverse_external_fqdn>server11.xxx.xx</reverse_external_fqdn>
    <reverse_http></reverse_http>
    <reverse_http_port></reverse_http_port>
    <reverse_http_defsite></reverse_http_defsite>
    <reverse_https></reverse_https>
    <reverse_https_port></reverse_https_port>
    <reverse_https_defsite></reverse_https_defsite>
    <reverse_ssl_cert></reverse_ssl_cert>
    <reverse_int_ca></reverse_int_ca>
    <deny_info_tcp_reset>on</deny_info_tcp_reset>
    <reverse_ignore_ssl_valid></reverse_ignore_ssl_valid>
    <reverse_owa></reverse_owa>
    <reverse_owa_ip>192.168.10.38</reverse_owa_ip>
    <reverse_owa_activesync></reverse_owa_activesync>
    <reverse_owa_rpchttp></reverse_owa_rpchttp>
    <reverse_cache_peer>SE9TVDE7MTkyLjE2OC4xMC4xMDs4MDtIVFRQ</reverse_cache_peer>
    <revrse_uri>VVJJMTtwdWJsaWM7d3d3Lnh4eC54eA=</revrse_uri>
    <reverse_acl>SE9TVDE7VVJJMQ==</reverse_acl>
    </config>
    </squidreverse>