Hyper-V VLAN issues



  • Issue below is seen in both pfSense and OPNsense
    I am completely baffled and looking for help.

    HOST Hyper-V 2012RS
    Quad Port Intel NIC
    Port1 - OS shared with HOST for management 10.15.30.x subnet LAN SWITCH
    Port2 not shared with HOST OS tied to physical broadband connection
    Port3 not shared with HOST OS tied tp physical LAN SWITCH
    Port4 not shared with HOST OS tied to secondary broadband - not part of this GUEST setup

    VswitchWAN tied to Port2
    VswitchLAN tied to Port3

    RUCKUS R600 Wireless AP
    SSID1 - no VLAN
    SSID2 - Access VLAN20

    Switches
    Dell PowerConnect series ALL PORTS set to TRUNK

    PowerShell - VswitchLAN set to trunk 20 with native 0

    GUEST OS
    pfSense or OPNsense
    Add VLAN 20
    Set interface parent to HN1 (LAN)
    Add DHCP server for VLAN Interface

    Everything works as expected. Wireless clients grab a lease from the VLAN subnet

    REBOOT firewall and the functionality breaks. I see no traffic in logs or DHCP requests on the VLAN subnet Setting a host to a static IP on the VLAN subnet also does not work, no traffic. I am at a loss.

    Removing interfaces, DHCP and adding them back restores functionality and leases are passed out and traffic flows until next reboot where everything breaks again. I am at a complete loss.

    Clearly I am doing something wrong with Hyper-V or the physical setup, but not sure what.

    FWIW - IHave tried adding additional vNICS to GUEST and configuring them to Access 20 - then adding the interface to pfSense or OPNsense - but I can not get traffic to flow this way.

    Looking for some help here - I really need to get this worked out.

    Thanks in advance!