2.4.4 upgrade messed pfBNG (beta)?!



  • After upgrading to 2.4.4 all seems to be fine except pfb_filter shows red status, after trying to start it I get PHP errors https://pastebin.com/tqc2m0CA

    I think I saw something about symlink fix, but can't find it ;(

    I was running pfBNG beta and see now "pfBlockerNG 2.1.4_12"

    @BBCAN117 help pls ? Maybe upgarde pfBNG to dev version ? (pfbupdate_sql.sh gui ran fine)



  • @BBCAN117 found your post in my email and tried:

    php -v vs php_pfb -v and they were different
    sudo rm /usr/local/bin/php_pf
    ln -s /usr/local/bin/php /usr/local/bin/php_pfb

    and then they were the same

    [2.4.4-RELEASE][admin@pfSense]/root: php_pfb -v
    PHP 7.2.10 (cli) (built: Sep 14 2018 11:32:18) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.10, Copyright (c) 1999-2018, by Zend Technologies
    vs
    [2.4.4-RELEASE][admin@pfSense]/root: php -v
    PHP 7.2.10 (cli) (built: Sep 14 2018 11:32:18) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.10, Copyright (c) 1999-2018, by Zend Technologies

    and then disabled enabled pfBNG and it seemed to be fixed.

    So posting for community benefit and FYI, make sure that this is a correct solution.


  • Moderator

    @chudak said in 2.4.4 upgrade messed pfBNG (beta)?!:

    sudo rm /usr/local/bin/php_pf
    ln -s /usr/local/bin/php /usr/local/bin/php_pfb

    There is a PR to fix this issue. Just waiting for the devs to approve.

    For others, running these commands will fix the issue:

    rm /usr/local/bin/php_pfb
    ln /usr/local/bin/php /usr/local/bin/php_pfb
    


  • @bbcan177 Thanks BBcan177. This fixed it for me 👍