Update to 2.4.4 Failed in Hyper-V 2012R2



  • pfsense just did an update from 2.4.3-RELEASE P1 (amd64) to 2.4.4, when it came back up there was no internet connection or access to anything and I kept getting a repeating error "pfctl: hn0: driver does not support altq". Curiously none of the other interfaces had this error. hn0 uses a Team of 4 NICs, is this likely to be an issue in 2.4.4, it was certainly fine in 2.4.3?

    Has something changed on traffic management or NIC drivers in this version to cause this error.

    In the end, I had to restore from Backup.

    Any thoughts anyone.

    Ian



  • @ianjanus

    UPDATE: By removing all traffic shaping I managed to get rid of the altq error but still nothing had access to the internet.

    I noticed on the reboot following the update pfsense stated that there was a system crash and provided the following information:

    Crash report begins. Anonymous machine information:

    amd64
    11.2-RELEASE-p3
    FreeBSD 11.2-RELEASE-p3 #17 e6b497fa0a3(RELENG_2_4_4): Thu Sep 20 09:04:45 EDT 2018 root@buildbot3:/crossbuild/ce-244/obj/amd64/WvDslnYb/crossbuild/ce-244/pfSense/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [30-Sep-2018 14:01:52 UTC] PHP Warning: Failed loading Zend extension 'opcache.so' (tried: /usr/local/lib/php/20131226/opcache.so (/usr/local/lib/php/20131226/opcache.so: Undefined symbol "zend_opcode_handlers"), /usr/local/lib/php/20131226/opcache.so.so (Cannot open "/usr/local/lib/php/20131226/opcache.so.so")) in Unknown on line 0
    [30-Sep-2018 14:01:52 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'session.so' (tried: /usr/local/lib/php/20131226/session.so (/usr/local/lib/php/20131226/session.so: Undefined symbol "zval_used_for_init"), /usr/local/lib/php/20131226/session.so.so (Cannot open "/usr/local/lib/php/20131226/session.so.so")) in Unknown on line 0
    [30-Sep-2018 14:01:52 UTC] PHP Warning: PHP Startup: bcmath: Unable to initialize module
    Module compiled with module API=20131226
    PHP compiled with module API=20170718
    These options need to match
    <<<<<<<<<<<<<<<<<<<<<<

    I have no idea if this is causing the problem. I had to roll back again to the previous version of pfsense. Any ideas?

    Ian


  • Netgate Administrator

    Somehow you still have php5.6 modules on the system after the upgrade. Those should have been replaced during the upgrade.
    It is expected to see php errors during the upgrade but not after rebooting subsequently.

    If you have packages installed try removing them before running the update and re-installing afterwards. The settings will be retained.

    Steve



  • @stephenw10 Thanks Steve for your helpful suggestions a good spot.

    I removed the ACME Let Encrypt package since that seemed to have a dependency on PHP and the update worked with no php errors, so a good step forward. However, I notice that my internet connection still does not work (PPPoE), it gets an IP address from my ISP and marks the interface as up but nothing can connect through it from any subnet.

    If I put another router in the way and change the interface to Static IPv4 it works fine, changing it back to PPPoE, again prevents anything from getting through. I also spotted that there is another post relating to PPPoE not working following upgrade to 2.4.4 (https://forum.netgate.com/topic/136136/pppoe-problems-after-upgrading-from-2-4-2-to-2-4-4), though it looks like his interface is marked down, whereas mine is marked up.

    I am keen to sort this since PPPoE is my normal internet connection method, having another router and double NATing is a configuration I would move away from.

    Kinr regards

    Ian


  • Netgate Administrator

    Check that is it set as the default gateway in System > Routing > Gateways.

    We have seen a few anomalies there where the Automatic setting doesn't correctly select it.

    Double check you have a default route In Diag > Routes when the PPPoE session is up.

    Steve



  • @stephenw10 Thanks again Steve. This seems to work for me. It is a little curious though because although the gateway selection was automatic, I had disabled the Stativ IPv4 gateway so that the only gateway available was the PPPoE one, clearly that wasn't sufficient!

    I have turned off automatic gateway selection and specified the PPPoE one under Gateways (seems to be a new field) - we used to specify the default gateway in the Interfaces section I think.

    Anyway, Thanks for your help. In slow time I will investigate why I cannt use traffic shaping this with version whereas I could with the previous one.

    Kind regards

    Ian


  • Netgate Administrator

    Yes the ability to choose a gateway group as the default is new in 2.4.4 as is the "Automatic" selection option. We have seen a few "quirks" with it, with disabled gateways especially. It's behaviour will be updated in 2.4.4p1.

    Steve